View Issue Details

IDProjectCategoryView StatusLast Update
0000969OpenMPT[All Projects] Generalpublic2017-08-02 12:46
ReporterZerroDeNullAssigned ToSaga Musix 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version8
Product VersionOpenMPT 1.27.00.* (old testing) 
Target VersionOpenMPT 1.26.12.00 / libopenmpt 0.2-beta26 (upgrade first)Fixed in VersionOpenMPT 1.26.12.00 / libopenmpt 0.2-beta26 (upgrade first) 
Summary0000969: Strange Sample and Instrument numbering jumps around 200
Description

I did try some thing and run into strange behavior
at sample 199 the create sample butten will stop to work with an error
after 199 instruments the create sample butten will start to work again
the error is the error because if you get around it it works and that is better than only 199 samples

Steps To Reproduce

Open new ompt module
go to sample view
click 200 times on the create new sample button

at sample 199 it will stop and say...
Error!
Too many samples!

now go to instruments view
click the create instrument button and when it asks for converting the samples to instruments say yes
now you have 199 empty samples and 1 empty instrument based on the empty sample 1
now click the create instrument button until you have 199 instruments based on 199 empty samples

now go back to sample view
and create a new sample with the button
now you get sample 200 with out Error! Too many samples!
it will ask to create an instrument, say yes
now you have 200 samples and 200 instruments based on them
now you can go on and create new samples and instruments

The question now is.... what exactly was this error?
the error does not realy make sence in that way

Additionaly i did search in the documentation under Sample and Instrument and About if there is some thing about samples limit or instruments limit or maximum or similar and i may did not look well but i saw nothing about limits

I think the error it self is an error because it seems to work if you get around it

Additional Information

if it is an error i like to ask for this as a feature

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

has duplicate 0000200 closed Sample Limit 

Activities

Saga Musix

Saga Musix

2017-06-08 23:05

administrator   ~0003063

Yes, you can have more samples in instrument mode. That is by design.
There is an additional 200-sample limit in sample mode for legacy reasons. However, I think it is time to up this limit to 255 to be consistent with the instrument limit.

Saga Musix

Saga Musix

2017-06-08 23:16

administrator   ~0003064

The limitation of 199 samples in sample mode has been removed in r8295, so you can have up to 255 samples - just like you can have up to 255 instruments in instrument mode.
However, you absolutely should be using the MPTM format in this case, as the original Impulse Tracker could only handle up to 99 samples and instruments, everything higher than that is stretching the IT specifications.

Issue History

Date Modified Username Field Change
2017-06-08 22:56 ZerroDeNull New Issue
2017-06-08 23:05 Saga Musix Priority high => low
2017-06-08 23:05 Saga Musix Note Added: 0003063
2017-06-08 23:16 Saga Musix Status new => resolved
2017-06-08 23:16 Saga Musix Resolution open => fixed
2017-06-08 23:16 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2017-06-08 23:16 Saga Musix Target Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first)
2017-06-08 23:16 Saga Musix Note Added: 0003064
2017-06-23 21:57 Saga Musix Assigned To => Saga Musix
2017-07-02 15:49 Saga Musix Fixed in Version OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) => OpenMPT 1.26.12.00 / libopenmpt 0.2-beta26 (upgrade first)
2017-07-02 15:49 Saga Musix Target Version OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (upgrade first) => OpenMPT 1.26.12.00 / libopenmpt 0.2-beta26 (upgrade first)
2017-08-02 12:46 Saga Musix Relationship added has duplicate 0000200