View Issue Details

IDProjectCategoryView StatusLast Update
0000200OpenMPT[All Projects] File Format Supportpublic2017-08-02 12:46
ReporterBrightstarAssigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionduplicate 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.19.04.00 (upgrade first) 
Target VersionFixed in Version 
Summary0000200: Sample Limit
Description

Unable to import any samples beyond a hard 199 sample limit. While one could simply add samples into samples to double their length thus getting one under the limit, it'd be nice if this limitation wasn't there.

Steps To Reproduce

Try to add over 199 samples to a file. Error is "Too many samples!"

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

duplicate of 0000969 resolvedSaga Musix Strange Sample and Instrument numbering jumps around 200 
child of 0000865 new Revised MPTM format - idea pool 

Activities

Saga Musix

Saga Musix

2011-10-17 07:21

administrator   ~0000525

You can reference up to 4000 samples in instrument mode (should only be done in the MPTM format, though). You will only be able to load up to 256 instruments, though, since you wouldn't be able to enter higher values into the pattern anyway (the instrument column is 8-Bit).

Issue History

Date Modified Username Field Change
2011-10-17 01:13 Brightstar New Issue
2011-10-17 07:21 Saga Musix Note Added: 0000525
2016-08-18 13:23 Saga Musix Relationship added child of 0000865
2017-08-02 12:46 Saga Musix Status new => closed
2017-08-02 12:46 Saga Musix Resolution open => duplicate
2017-08-02 12:46 Saga Musix Relationship added duplicate of 0000969