View Issue Details

IDProjectCategoryView StatusLast Update
0000892OpenMPT[All Projects] User Interfacepublic2017-04-06 14:23
ReporterSuperDiskAssigned To 
PrioritynormalSeverityminorReproducibilityunable to reproduce
Status closedResolutionno change required 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.26.07.00 / libopenmpt 0.2-beta20.3 (upgrade first) 
Target VersionFixed in Version 
Summary0000892: Drag and dropping samples into the sampler doesn't work.
Description

Previously dropping sample files (or just any file really) would load it. Now it does nothing. This was a pretty crucial part of my workflow.

Steps To Reproduce
  • Drag a file onto the black sample area in the sample tab
  • Witness as it does not load.
Tagsuser interface, Windows 10 Bug
Has the bug occurred in previous versions?

No

Tested code revision (in case you know it)

Activities

StarWolf3000

StarWolf3000

2016-11-22 06:59

reporter   ~0002742

Cannot reproduce this.

Have 1.26.07.00 and loading sample files by drag'n'drop them works as expected.

Works with Windows 7 64-bit, Windows 8.1 64-bit and Windows 10 64-bit.

Saga Musix

Saga Musix

2016-11-22 13:26

administrator   ~0002744

Works just fine here as well. Where do you drag the files from? From OpenMPT's internal tree view or from Explorer?

Note that drag&drop between explorer and OpenMPT (or any other application) does not work if you run OpenMPT with administrator privileges (e.g. because of troublesome plugins).

StarWolf3000

StarWolf3000

2016-11-22 13:37

reporter   ~0002748

It never works from Explorer, if OpenMPT is actually run as Administrator, because the way the Explorer process works, it always runs as the current user, except if you're logged in with the Administrator account itself.

I have this non-working drag'n'drop, when I explicitely run Notepad++ as Administrator for example. In that case, Explorer runs in User mode, while Notepad++ runs as Administrator. They are not compatible in this case for drag'n'drop operations. The same goes for OpenMPT and a lot other applications.

SuperDisk

SuperDisk

2016-11-24 02:54

reporter   ~0002763

After a little more mucking around, I think I've found the problem- dragging and dropping sample files is somehow treating them "as a module".... In the sense that if you started with a blank MDI (no modules open) and drop in a sample, it would create a new module for you with just that sample loaded. When I'm dropping stuff into the sampler, it's trying to load it in that manner instead of just as a sample for some reason.

The reason it was previously doing "nothing" was because I was dropping raw PCM into the sampler- something that cannot be loaded "as a module." I tried dropping a WAV into the sampler and it loaded it "as a module" (created a new module with one sample).

Are you guys experiencing this too?

StarWolf3000

StarWolf3000

2016-11-24 07:12

reporter   ~0002764

Did you actually drop it onto the waveform area on the Samples tab or just somewhere on the OpenMPT window?

If you drop it outside the waveform area, a new module will be created (if the file is actually readable).

Also would be nice to have a sample raw PCM file.

SuperDisk

SuperDisk

2016-11-24 07:20

reporter   ~0002765

I indeed did drop it into the waveform area. As for a sample raw PCM file, it doesn't really matter, you can just drop a jpeg or something.

Saga Musix

Saga Musix

2016-11-24 12:31

administrator   ~0002766

Please provide an example file to reproduce the problem with. Dropping a WAV file in the black sample area should load it as a normal sample. Dropping a WAV file anywhere else should load it as a module. Dropping a module on the black sample area should load it as a module in the tree view for sample extraction.

SuperDisk

SuperDisk

2016-11-28 05:17

reporter   ~0002798

Here's a video of the bug in action. Basically, dragging and dropping alternately does nothing and opens a sample file as a module.

https://www.youtube.com/watch?v=7yujqOkQ0hE

I should have noted earlier- I'm using the latest Win 10 insider preview: Build 14965. That might be it really.

Saga Musix

Saga Musix

2016-11-28 12:53

administrator   ~0002799

Sounds to me like it might be the reason. I'll see later if I can upgrade my Win10 VM to the latest insider build and reproduce it there. Maybe you can give some feedback to Microsoft through that start menu thingy that Drag&Drop appears to be broken in this build?

Saga Musix

Saga Musix

2017-01-12 00:45

administrator   ~0002835

Is this still an issue? I still cannot reproduce it on Windows 10.

SuperDisk

SuperDisk

2017-01-14 02:52

reporter   ~0002843

Hi, I've made some headway on this issue. The bug is totally resolved if I override the scaling options and (what seems to be) perform no scaling. I have a high DPI monitor so I typically use 175% scaling in the Windows settings.[img]https://i.sli.mg/26QSpo.png[/img]This makes drag 'n drop work again, however this has the unintended side effect of making everything really small and almost unusable:[img]https://i.sli.mg/bAZk1T.png[/img]This implies either you guys maybe changed the drop rectangles a while ago, or Windows updated the OS and broke it, since it did previously work like normal.

SuperDisk

SuperDisk

2017-01-14 02:52

reporter   ~0002844

My images didn't embed, so here are their URLs:https://i.sli.mg/26QSpo.pnghttps://i.sli.mg/bAZk1T.png

Saga Musix

Saga Musix

2017-01-14 13:27

administrator   ~0002847

Last edited: 2017-03-02 14:55

View 2 revisions

There is no such thing as a "drop rectangle" here - the entire sample editor area is a drop target. But Microsoft is really good at breaking scaling options, so you could maybe try to submit some feedback (which I think was possible through the start menu when you're an insider?)

This makes drag 'n drop work again, however this has the unintended side effect of making everything really small and almost unusable

By "everything" you really just mean the icons, right? Those will hopefully be fixed soon for high-DPI devices, but as far as I'm aware (0000627), there is nothing else that should keep you from using an unscaled high-DPI version of OpenMPT, unless you are using VST plugins (we cannot do anything in that case, since plugins draw their own UI). The pattern font can be enlarged in the settings dialog.

Saga Musix

Saga Musix

2017-03-02 15:00

administrator   ~0002899

Is this still an issue? I just installed the latest updates on my Windows 10 VM and still cannot reproduce this. Theoretically I'm signed up for insider builds but I think it doesn't download those for some reason.

jmkz

jmkz

2017-03-06 04:32

reporter   ~0002902

I also have a similar issue. I've noticed that .wav files are treated as folders, as can be enabled in tree view. However, it doesn't happen in v1.26.08, notice the .wav files listed. Maybe it's a new feature (I've not searched yet)



latest_dev.png (43,365 bytes)
latest_dev.png (43,365 bytes)
latest_stable.png (33,755 bytes)
latest_stable.png (33,755 bytes)
Saga Musix

Saga Musix

2017-03-06 10:59

administrator   ~0002903

This has nothing to do with the problem in this issue at all and is just a temporary issue that will be resolved soon.

Monsterovich

Monsterovich

2017-03-07 07:55

reporter   ~0002904

http://www.zimagez.com/zimage/2017-03-0709-51-05.php

OpenMPT says that flac format is not supported.

Saga Musix

Saga Musix

2017-03-07 10:43

administrator   ~0002905

How/where did you try to load the file? This message indicates that OpenMPT tried to load the file as a module, and not into a sample slot.

Saga Musix

Saga Musix

2017-04-06 13:49

administrator   ~0002969

I installed to Windows 10 Creators Update and the problem can still not be reproduced.

SuperDisk

SuperDisk

2017-04-06 14:19

reporter   ~0002970

I ended up doing a fresh install of Windows and not getting back on the insider program, and it's all working like usual now so I think it was just some Windows bug.

I got stuck on a particularly nasty/buggy build and it was taking forever for them to deploy an update for me to get off it, so that's why I reformatted. I think it's safe to say this issue can be closed.

Saga Musix

Saga Musix

2017-04-06 14:23

administrator   ~0002971

Thanks for the feedback!

Issue History

Date Modified Username Field Change
2016-11-22 02:16 SuperDisk New Issue
2016-11-22 02:16 SuperDisk Tag Attached: sample
2016-11-22 02:16 SuperDisk Tag Attached: user interface
2016-11-22 06:59 StarWolf3000 Note Added: 0002742
2016-11-22 13:26 Saga Musix Note Added: 0002744
2016-11-22 13:30 Saga Musix Reproducibility always => unable to reproduce
2016-11-22 13:37 StarWolf3000 Note Added: 0002748
2016-11-24 02:54 SuperDisk Note Added: 0002763
2016-11-24 07:12 StarWolf3000 Note Added: 0002764
2016-11-24 07:20 SuperDisk Note Added: 0002765
2016-11-24 12:31 Saga Musix Note Added: 0002766
2016-11-28 05:17 SuperDisk Note Added: 0002798
2016-11-28 12:53 Saga Musix Note Added: 0002799
2017-01-12 00:45 Saga Musix Note Added: 0002835
2017-01-14 02:52 SuperDisk Note Added: 0002843
2017-01-14 02:52 SuperDisk Note Added: 0002844
2017-01-14 13:27 Saga Musix Note Added: 0002847
2017-03-02 14:55 Saga Musix Note Edited: 0002847 View Revisions
2017-03-02 15:00 Saga Musix Note Added: 0002899
2017-03-06 04:32 jmkz File Added: latest_dev.png
2017-03-06 04:32 jmkz File Added: latest_stable.png
2017-03-06 04:32 jmkz Note Added: 0002902
2017-03-06 10:59 Saga Musix Note Added: 0002903
2017-03-06 15:05 Saga Musix Steps to Reproduce Updated View Revisions
2017-03-07 07:55 Monsterovich Note Added: 0002904
2017-03-07 10:43 Saga Musix Note Added: 0002905
2017-03-28 19:04 Saga Musix Tag Attached: Windows 10 Bug
2017-04-06 13:49 Saga Musix Note Added: 0002969
2017-04-06 13:49 Saga Musix Tag Detached: sample
2017-04-06 14:19 SuperDisk Note Added: 0002970
2017-04-06 14:23 Saga Musix Status new => closed
2017-04-06 14:23 Saga Musix Resolution open => no change required
2017-04-06 14:23 Saga Musix Note Added: 0002971