View Issue Details

IDProjectCategoryView StatusLast Update
0000070OpenMPT[All Projects] File Format Supportpublic2011-03-04 16:46
Reporter404notfoundAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindowsOS Version7
Product VersionOpenMPT 1.19.00.* (old testing) 
Target VersionOpenMPT 1.19.01.00 (upgrade first)Fixed in VersionOpenMPT 1.19.01.00 (upgrade first) 
Summary0000070: Broken default sample loop-points in some tunes
Description

Currently tested in v.24 and I think v.20.
For some reason, the unlooped samples in these tunes have a default two sample long loop, possibly because of the importer.

TagsNo tags attached.
Has the bug occurred in previous versions?Tested in 1.17.02.54 (no faulty loop) and 1.18.03.00 (loop present)
Tested code revision (in case you know it)

Activities

404notfound

404notfound

2011-02-15 00:03

reporter  

FutureShock3000.zip (309,387 bytes)
Saga Musix

Saga Musix

2011-02-15 23:22

administrator   ~0000069

I suspect that a broken converter was used for creating the AMF file (since the original tune is a MOD file and loop lengths <= 2 practically mean "no loop" in MOD), but I'll look into fixing this.

Saga Musix

Saga Musix

2011-02-24 15:32

administrator   ~0000072

Revision 801 should fix these issues. Please confirm that http://sagagames.de/stuff/mptrack.exe works correctly.

404notfound

404notfound

2011-03-04 16:45

reporter   ~0000082

Sorry for the delay, fix confirmed. Also added some info in the previous version field.

Issue History

Date Modified Username Field Change
2011-02-15 00:03 404notfound New Issue
2011-02-15 00:03 404notfound File Added: FutureShock3000.zip
2011-02-15 23:22 Saga Musix Note Added: 0000069
2011-02-15 23:22 Saga Musix Assigned To => Saga Musix
2011-02-15 23:22 Saga Musix Status new => assigned
2011-02-15 23:29 Saga Musix Priority high => normal
2011-02-15 23:29 Saga Musix Category Playback Compatibility => File Format Support
2011-02-15 23:29 Saga Musix Target Version => OpenMPT 1.19.01.00 (upgrade first)
2011-02-24 15:32 Saga Musix Note Added: 0000072
2011-02-24 15:32 Saga Musix Status assigned => feedback
2011-03-04 16:43 404notfound Has the bug occurred in previous versions? Haven't tested much, but I think it's recent. => Tested in 1.17.02.54 (no faulty loop) and 1.18.03.00 (loop present)
2011-03-04 16:45 404notfound Note Added: 0000082
2011-03-04 16:45 404notfound Status feedback => assigned
2011-03-04 16:46 Saga Musix Status assigned => resolved
2011-03-04 16:46 Saga Musix Resolution open => fixed
2011-03-04 16:46 Saga Musix Fixed in Version => OpenMPT 1.19.00.* (old testing)