View Issue Details

IDProjectCategoryView StatusLast Update
0000381OpenMPT[All Projects] File Format Supportpublic2018-06-12 22:07
ReporterNero1024Assigned ToSaga Musix 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionOpenMPT 1.28.01.00 (goals)Fixed in VersionOpenMPT 1.28.01.00 (goals) 
Summary0000381: FM Synth for S3M Modules
Description

According to Wikipedia the S3M format supports FM instruments (though it's rarely used apparently). Is there any chance that OpenMPT will support FM synth for S3M modules?

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

duplicate of 0000619 closed Cannot play certain S3M's - No AdLib Instrument Support 

Activities

Saga Musix

Saga Musix

2013-04-24 12:14

administrator   ~0001193

This has been considered before, and it's not going to happen. Use ScreamTracker in DOSBox or SchismTracker (which isn't 100% correct, but close enough I guess). There is not going to be any support for synthesized instruments (S3M+AdLib, Oktamed, AHX, ...).

Saga Musix

Saga Musix

2018-05-23 11:30

administrator   ~0003532

Reopening as there is now a public-domain OPL3 emulator that we can use in OpenMPT/libopenmpt.

Saga Musix

Saga Musix

2018-05-28 09:55

administrator   ~0003535

r10307 adds support for OPL instruments. They cannot be edited yet, only loaded and saved. Adlib S3M files are played correctly. The UI for editing OPL instruments is still to be done.

Saga Musix

Saga Musix

2018-06-12 22:07

administrator   ~0003557

Support for editing has been added in the meantime, but some improvements are still to be done:

  • Maybe have different icons for OPL instruments in the tree view
  • Add a possibility to create new OPL instruments without having to import one first
  • Copy&Paste for OPL instruments

Issue History

Date Modified Username Field Change
2013-04-24 11:05 Nero1024 New Issue
2013-04-24 12:14 Saga Musix Note Added: 0001193
2013-04-24 12:14 Saga Musix Status new => closed
2013-04-24 12:14 Saga Musix Resolution open => won't fix
2018-05-23 11:30 Saga Musix Assigned To => Saga Musix
2018-05-23 11:30 Saga Musix Status closed => assigned
2018-05-23 11:30 Saga Musix Note Added: 0003532
2018-05-23 11:31 Saga Musix Resolution won't fix => open
2018-05-23 11:31 Saga Musix Target Version => OpenMPT 1.28.01.00 (goals)
2018-05-23 11:31 Saga Musix Relationship added duplicate of 0000619
2018-05-28 09:55 Saga Musix Status assigned => resolved
2018-05-28 09:55 Saga Musix Resolution open => fixed
2018-05-28 09:55 Saga Musix Fixed in Version => OpenMPT 1.28.01.00 (goals)
2018-05-28 09:55 Saga Musix Note Added: 0003535
2018-06-12 22:07 Saga Musix Note Added: 0003557