View Issue Details

IDProjectCategoryView StatusLast Update
0001512OpenMPTFeature Requestpublic2021-10-11 14:28
Reporterjrmoserbaltimore Assigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionwon't fix 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.30.00.* (current testing) 
Summary0001512: Integrate ymfm as FM synthesis core
Description

Aaron Giles's ymfm library emulates several Yamaha FM chips and PSGs, under a BSD 3-clause license. Shipping OpenMPT with a packaged ymfm library is feasible license-wise. Longer term, future versions of MPTM could support the various chips provided, as UI elements are added to interface with the ymfm library.

https://github.com/aaronsgiles/ymfm

Currently, ymfm supports the OPM, OPN, OPL, OPQ, and OPZ series, which include the chips used in Yamaha's DX11, DX21, DX27, and DX100. OPS (DX7, such as in Dexed) is a future target. This leaves some significant flexibility in future decisions on what to support. OPL3 is limited in fundamental ways, and OPM, OPZ, or OPS support would be an immense improvement to FM synthesis capabilities. Whether it's reasonable to support every chip under the sun or only two or three carefully selected options is another matter; the two most notable chips in professional FM synthesis are probably the OPM/OPP (used in a lot of Yamaha synthesizers) and the OPS (as a DX7 emulator).

https://gist.github.com/bryc/e85315f758ff3eced19d2d4fdeef01c5

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2021-10-11 14:28

administrator   ~0004887

Essentially the same reply as for 0001500: It's not OpenMPT's goal to be a collection of random synthesizers. The only reason why there is a built-in OPL emulator is because it's required for full support of the S3M format. We have absolutely no intents to add support for more synthesizers outside of those that are required to play already-supported module formats. Other sound sources are best added as plugins by the users.

Issue History

Date Modified Username Field Change
2021-10-11 14:20 jrmoserbaltimore New Issue
2021-10-11 14:28 Saga Musix Note Added: 0004887
2021-10-11 14:28 Saga Musix Status new => closed
2021-10-11 14:28 Saga Musix Resolution open => won't fix