View Issue Details

IDProjectCategoryView StatusLast Update
0001500OpenMPTFeature Requestpublic2021-09-08 07:03
Reporterjrmoserbaltimore Assigned To 
PrioritylowSeverityfeatureReproducibilityN/A
Status closedResolutionwon't fix 
Product VersionOpenMPT 1.30.00.* (current testing) 
Summary0001500: Reface DX Instruments
Description

Simple feature request for an instrument editor and FM synthesizer for the Yamaha Reface DX. This is a low-cost keyboard and 4-op FM synthesizer with 12 algorithms.

Yamaha provides documentation for accessing the Reface series to read or write patches via MIDI in the "Reface Data List" below.

https://usa.yamaha.com/files/download/other_assets/7/794817/reface_en_dl_b0.pdf

Additional Information

It is sufficient to provide the synthesizer itself. Implementing a transfer feature to copy patches from or to the Reface DX itself would be a useful feature. This approach would still require a Reface DX, which although low cost still comes at a cost. Low-income users may have difficulty finding $300 in their budget.

When connected as a MIDI instrument, the Reface DX is automatically programmed by the Soundmondo Web site. OpenMPT could expose itself as a MIDI instrument and respond to certain MIDI commands with the responses documented by Yamaha to achieve the same without the $300 instrument.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2021-09-08 07:03

administrator   ~0004856

It is sufficient to provide the synthesizer itself.

It is also the most complicated part, and most likely a violation of copyright and whatnot (and much more high-risk than OPL for which patents have expired and the chip itself is no longer produced). That will most definitely not happen. I mean, the only way I could even potentially consider this if some external project writes that synthesizer. I surely will not write that synthesizer by myself because that will effectively halt work pretty much any other more important OpenMPT feature for a considerable amount of time.

Implementing a transfer feature to copy patches from or to the Reface DX itself would be a useful feature.

There are thousands of synthesizers out there, I see no reason why OpenMPT should single out any specific synthesizer and add a programmer for it. It would make more sense to implement this as a VST. Sonic Quest's Midi Quest ediors would be a good choice for that but it's a bit on the pricy side. Ctrlr might be a viable free alternative.

Low-income users may have difficulty finding $300 in their budget.

There are many, many free alternatives available as plugins already. Try Dexed, which is a faithful recreation of the Yamaha DX7 and can be loaded as a VST in OpenMPT.

Issue History

Date Modified Username Field Change
2021-09-08 01:47 jrmoserbaltimore New Issue
2021-09-08 07:03 Saga Musix Note Added: 0004856
2021-09-08 07:03 Saga Musix Status new => closed
2021-09-08 07:03 Saga Musix Resolution open => won't fix