View Issue Details

IDProjectCategoryView StatusLast Update
0001467OpenMPTGeneralpublic2021-08-31 18:10
ReporterSaga Musix Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.30.00.* (current testing) 
Target VersionOpenMPT 1.30 / libopenmpt 0.6 (goals)Fixed in VersionOpenMPT 1.30 / libopenmpt 0.6 (goals) 
Summary0001467: Shortcuts assigned to MIDI notes trigger on both note-on and note-off
Description

Assigning a shortcut to MIDI notes triggers both on note-on and note-off. Ideally, note-on and note-off should map to the "key down" and "key up" check boxes so that the user can decide which action should trigger what.

No matter what the solution to this problem looks like, it most likely cannot be stateless: For each note-on event, we need to memorize that the corresponding note-off event should not be processed any further and e.g. cause a note-off to be written to the pattern editor. On the other hand, if a shortcut is only triggered by note-off, this note-off should still be processed by other parts of the program that might have processed the note-on event, or that note will keep hanging forever.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

related to 0001396 resolvedSaga Musix Can we get more midi controller capablity? 

Activities

Saga Musix

Saga Musix

2021-08-31 18:10

administrator   ~0004852

Fixed in r15596.

Issue History

Date Modified Username Field Change
2021-06-02 22:51 Saga Musix New Issue
2021-06-02 22:51 Saga Musix Status new => assigned
2021-06-02 22:51 Saga Musix Assigned To => Saga Musix
2021-06-02 22:51 Saga Musix Relationship added related to 0001396
2021-06-02 22:52 Saga Musix Description Updated
2021-08-31 18:10 Saga Musix Status assigned => resolved
2021-08-31 18:10 Saga Musix Resolution open => fixed
2021-08-31 18:10 Saga Musix Fixed in Version => OpenMPT 1.30 / libopenmpt 0.6 (goals)
2021-08-31 18:10 Saga Musix Note Added: 0004852