View Issue Details

IDProjectCategoryView StatusLast Update
0001396OpenMPTFeature Requestpublic2020-12-22 12:11
ReporterExhale Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Target VersionOpenMPT 1.30 / libopenmpt 0.6 (goals)Fixed in VersionOpenMPT 1.30 / libopenmpt 0.6 (goals) 
Summary0001396: Can we get more midi controller capablity?
Description

I have an AKAI apc key25, it has a little keyboard, a lot of lauch buttons which have lights and about 8 dials... the 8 dials work great for plugins... I can set them and everything, the keyboard is great for inputting midi notes, but if I want my launch buttons to work and include lights, I have to have other software installed that passes eveything else through but intercepts the lauch buttons... when I have used this in the past I managed to learn a little bit about how to make the lights work and I tended to apply keyboard shortcuts or combinations of keyboard shortcuts to the lauch buttons so it would take me to channels relative to the one I have highlighted, and for a while I had great channel mute and other controls set to it... unfortuantely that computer died before I could get those settings and bring them to my newer computer and it was a difficult process.

What I am asking is can we have midi mapping controls that we can give keyboard shortcuts or combinations of it... for example my akai's lauch pad goes from c-0 at the bottom right corner to g#1 top left corner when I am set to octave 3 on modplug - the octave up and octave down buttons work with their lights (this must be coded internally) but all the rest of the buttons have notes applied... stuff like play/pause is g-6
I would really love to be able to put the lights on for the various internally programmed colours and flashing patterns with customization, but I would happily settle for whatever funtionality you can give me...

TLDR - I would like to apply keyboard shortcuts with my midi controller within modplug using the midi mapping settings and specifically be able to apply them to relative notes so my launch pad can have some functionality outside of the keyboard and dials.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2020-12-06 11:55

administrator   ~0004541

You can already bind MIDI CCs to keyboard shortcuts. Is it maybe possible to reprogram the device so that it sends CCs instead of MIDI notes?

Exhale

Exhale

2020-12-06 14:13

reporter   ~0004542

I will see what I can find out... thanks for the direction to look

Exhale

Exhale

2020-12-06 14:42

reporter   ~0004543

I am doing my best to wrap my head around it... I found this forum (end)- where they seem to be talking about the akai I have and mention midi to cc translation and maybe I will figure it out... I am not sure if the one I have is known for having this problem... I am checking out bomes though, I think that was the software I used to make the lights happen which will be awesome.
https://forum.ableton.com/viewtopic.php?t=226020

Exhale

Exhale

2020-12-06 14:47

reporter   ~0004544

ok I have looked in a few places and yeah bome seems to be the thing I need to convert midi notes to cc and very likely what I used before but I dont think the free version (classic) does it actually. hmmm...

Exhale

Exhale

2020-12-06 15:19

reporter   ~0004545

ok I think the other thing/things I was using was midikey2key and maybe midiox... so I am getting both and holding thumbs that I might be able to work it out... idk why but bome doesnt seem to be seeing my akai... but I can hope that will be sorted with a reset later. anyways thank you for a little bit of memory jogging of the kind of thing I should be looking into. And if I can just convert them to cc commands I should be golden to control the rest in moplug. :) you have been very helpful thank you... I will get back to you... but maybe that is something you might consider putting into modplug is the capacity to turn note hits into keyboard commands and changes in vsts as well as the cc commands... as you can see in my case that would be a useful addition meaning I could forgo this other software.

Exhale

Exhale

2020-12-06 15:36

reporter   ~0004546

ok getting bome to do some of what I want here... the midi device has a sensitive cable or something... I had forgotten

Saga Musix

Saga Musix

2020-12-19 16:45

administrator   ~0004553

r13966 (soon available from https://builds.openmpt.org/builds/auto/openmpt/pkg.win/) will also have MIDI notes in addition to MIDI CCs as possible MIDI input for shortcuts.

Exhale

Exhale

2020-12-22 12:09

reporter   ~0004555

Thank you Saga, this is the best Xmas present ever T_T.
Have a great one guys.

Issue History

Date Modified Username Field Change
2020-12-06 10:04 Exhale New Issue
2020-12-06 11:55 Saga Musix Note Added: 0004541
2020-12-06 14:13 Exhale Note Added: 0004542
2020-12-06 14:42 Exhale Note Added: 0004543
2020-12-06 14:47 Exhale Note Added: 0004544
2020-12-06 15:19 Exhale Note Added: 0004545
2020-12-06 15:36 Exhale Note Added: 0004546
2020-12-19 16:45 Saga Musix Assigned To => Saga Musix
2020-12-19 16:45 Saga Musix Status new => feedback
2020-12-19 16:45 Saga Musix Note Added: 0004553
2020-12-22 12:09 Exhale Note Added: 0004555
2020-12-22 12:09 Exhale Status feedback => assigned
2020-12-22 12:11 Saga Musix Status assigned => resolved
2020-12-22 12:11 Saga Musix Resolution open => fixed
2020-12-22 12:11 Saga Musix Fixed in Version => OpenMPT 1.30 / libopenmpt 0.6 (goals)
2020-12-22 12:11 Saga Musix Target Version => OpenMPT 1.30 / libopenmpt 0.6 (goals)