View Issue Details

IDProjectCategoryView StatusLast Update
0001446OpenMPTFile Format Supportpublic2021-04-15 21:01
Reporter404notfound Assigned ToSaga Musix  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product VersionOpenMPT 1.30.00.* (current testing) 
Target VersionOpenMPT 1.30 / libopenmpt 0.6 (goals)Fixed in VersionOpenMPT 1.30 / libopenmpt 0.6 (goals) 
Summary0001446: Missing notes in certain ADLIBSP.S3M
Description

There are missing notes at the end of first pattern in chan8 in attached adlib song.
Version 1.30.00.33-r14605 RETRO was used.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

404notfound

404notfound

2021-04-15 18:22

reporter   ~0004709

Oh shoot, it didn't attach my file.

ADLIBSP.zip (1,484 bytes)
Saga Musix

Saga Musix

2021-04-15 21:01

administrator   ~0004712

Fixed in r14612 / 1.30.00.34. Won't backport to 1.28 / 1.29 because it would change behaviour of S3Ms saved with future 1.29 versions.

Issue History

Date Modified Username Field Change
2021-04-15 18:20 404notfound New Issue
2021-04-15 18:22 404notfound Note Added: 0004709
2021-04-15 18:22 404notfound File Added: ADLIBSP.zip
2021-04-15 20:48 Saga Musix Assigned To => Saga Musix
2021-04-15 20:48 Saga Musix Status new => assigned
2021-04-15 21:01 Saga Musix Status assigned => resolved
2021-04-15 21:01 Saga Musix Resolution open => fixed
2021-04-15 21:01 Saga Musix Fixed in Version => OpenMPT 1.30 / libopenmpt 0.6 (goals)
2021-04-15 21:01 Saga Musix Target Version => OpenMPT 1.30 / libopenmpt 0.6 (goals)
2021-04-15 21:01 Saga Musix Note Added: 0004712