View Issue Details

IDProjectCategoryView StatusLast Update
0001331OpenMPTGeneralpublic2020-10-04 14:57
ReporterMidori Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product VersionOpenMPT 1.29.01.00 / libopenmpt 0.5.0 (upgrade first) 
Target VersionOpenMPT 1.29.05.00 / libopenmpt 0.5.3 (current stable)Fixed in VersionOpenMPT 1.29.05.00 / libopenmpt 0.5.3 (current stable) 
Summary0001331: S3M module per-channel stem export is desynchronised
Description

Rendering an S3M module into separate channel stems produces tracks that are of different length, thus misaligned in time.

Steps To Reproduce

1, Load an S3M module (the only test subject in my case was https://modarchive.org/index.php?request=view_by_moduleid&query=60395)

  1. Enable the "Channel mode" checkbox

  2. Render the audio and load all the stems into your audio editor of choice

Additional Information

This was first observed by another person, using v.1.29 on a Windows 7 x64 machine, after rendering this module: https://modarchive.org/index.php?request=view_by_moduleid&query=60395

I was able to reproduce it on my XP machine, both in v.1.28 and latest stable 1.29 using the same file. Other S3M/XM/MPTM modules were not tested. IT seems to be unaffected in both versions of the tracker.

Attached are the screnshots of the faulty S3M export and correct IT export, as seen loaded into FL Studio.

TagsNo tags attached.
Has the bug occurred in previous versions?Yes, only 1.28 tested
Tested code revision (in case you know it)

Relationships

has duplicate 0001375 closed [S3M] Commands that affect playback globally do not get parsed when their channel is muted 

Activities

Midori

Midori

2020-05-28 16:15

reporter  

S3M_Desync_MPT_v1.28.PNG (174,658 bytes)   
S3M_Desync_MPT_v1.28.PNG (174,658 bytes)   
IT_CorrectExport_MPT_v1.29.PNG (194,010 bytes)   
IT_CorrectExport_MPT_v1.29.PNG (194,010 bytes)   
Saga Musix

Saga Musix

2020-05-28 16:16

administrator   ~0004354

Makes sense because global commands (that includes tempo changes) are not executed on muted channels in S3M. For the time being, you can turn off that specific compatibility setting before exporting, but I guess a better solution has to be found for export.

Saga Musix

Saga Musix

2020-10-04 14:57

administrator   ~0004455

Stream export is fixed in r13652.

Issue History

Date Modified Username Field Change
2020-05-28 16:15 Midori New Issue
2020-05-28 16:15 Midori File Added: S3M_Desync_MPT_v1.28.PNG
2020-05-28 16:15 Midori File Added: IT_CorrectExport_MPT_v1.29.PNG
2020-05-28 16:16 Saga Musix Note Added: 0004354
2020-10-04 14:11 Saga Musix Relationship added has duplicate 0001375
2020-10-04 14:30 Saga Musix Assigned To => Saga Musix
2020-10-04 14:30 Saga Musix Status new => assigned
2020-10-04 14:57 Saga Musix Note Added: 0004455
2020-10-04 14:57 Saga Musix Status assigned => resolved
2020-10-04 14:57 Saga Musix Resolution open => fixed
2020-10-04 14:57 Saga Musix Fixed in Version => OpenMPT 1.29.05.00 / libopenmpt 0.5.3 (current stable)
2020-10-04 14:57 Saga Musix Target Version => OpenMPT 1.29.05.00 / libopenmpt 0.5.3 (current stable)