View Issue Details

IDProjectCategoryView StatusLast Update
0001320OpenMPTFile Format Supportpublic2020-05-07 18:11
ReporterSaga Musix Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Target VersionOpenMPT 1.29.01.00 / libopenmpt 0.5.0 (current stable)Fixed in VersionOpenMPT 1.29.01.00 / libopenmpt 0.5.0 (current stable) 
Summary0001320: SF2: Support multiple instruments per preset
Description

Currently only one instrument per SF2 preset is considered. While this is often okay because we do not support velocity layers, it is troublesome with drum programs in SGM 2.0 which are comprised of several instruments addressing different types of drums. In addition, the drum programs in SGM 2.0 are detuned because they set the scale tuning to 0 cents per semitone, which is currently not honored by OpenMPT.

Additional Information

Code is almost ready, just needs some cleanup and more testing.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2020-05-07 18:11

administrator   ~0004306

Fixed in r12782

Issue History

Date Modified Username Field Change
2020-05-06 21:19 Saga Musix New Issue
2020-05-06 21:19 Saga Musix Status new => assigned
2020-05-06 21:19 Saga Musix Assigned To => Saga Musix
2020-05-07 18:11 Saga Musix Status assigned => resolved
2020-05-07 18:11 Saga Musix Resolution open => fixed
2020-05-07 18:11 Saga Musix Fixed in Version => OpenMPT 1.29.01.00 / libopenmpt 0.5.0 (current stable)
2020-05-07 18:11 Saga Musix Note Added: 0004306