View Issue Details

IDProjectCategoryView StatusLast Update
0001290OpenMPTPlugins / VSTpublic2020-01-12 14:44
Reporterjmkz Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionnot fixable 
Platformx64OSWindows 
Product VersionOpenMPT 1.29.00.* (current testing) 
Summary0001290: Crash files from when opening Channel Matrix 2x2 plugin window
Description

Crash after trying to open RS-MET Channel Matrix 2x2 plugin.

Compressed file: https://drive.google.com/open?id=1mbHi13gO_bcVN6V1BSdzM339sKBZ_3t8

Steps To Reproduce

Opened a song that has this plugin enabled, then cliked [Edit...] button to show its window and crashed.

Additional Information

If possible, what have changed that was not triggered from earlier versions of OpenMPT?

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)r12478

Relationships

duplicate of 0001012 closed VST SignalAnalyzer causes crash when opened 
related to 0001291 new Separate plugin bridge versions for legacy / buggy plugins 

Activities

Saga Musix

Saga Musix

2020-01-12 12:17

administrator   ~0004189

Well, the crash is happening inside the plugin. Which OpenMPT was the last one in which the plugin worked for you?

Saga Musix

Saga Musix

2020-01-12 12:48

administrator   ~0004190

Seems like the crash was introduced in r5340, which adds an operating system compatibility manifest to the OpenMPT and Plugin Bridge executables, thus declaring compatbility with Windows 7 and newer. Obviously we cannot go back to pretending that we don't know about more modern Windows versions, so if you absolutely must run this plugin, you can override OpenMPT's compatibility settings by going to the file properties of the OpenMPT executable and changing compatibility back to Windows 8 or earlier, but I'd rather recommend you find a replacement for this plugin that doesn't require such a hack. I suspect that the plugin does something that upsets Windows 10 and as a consequence is not compatible with any host that declares compatibility with Windows 10.

Saga Musix

Saga Musix

2020-01-12 12:58

administrator   ~0004191

Last edited: 2020-01-12 13:04

View 2 revisions

This also affects other RS-MET plugins on Windows 10, see related issue 0001012.

Edit: Now also covered in the plugin compatibility list: https://wiki.openmpt.org/Manual:_Known_Issues#RS-MET_Plugins

Issue History

Date Modified Username Field Change
2020-01-12 09:49 jmkz New Issue
2020-01-12 12:17 Saga Musix Note Added: 0004189
2020-01-12 12:48 Saga Musix Status new => closed
2020-01-12 12:48 Saga Musix Resolution open => not fixable
2020-01-12 12:48 Saga Musix Note Added: 0004190
2020-01-12 12:58 Saga Musix Relationship added duplicate of 0001012
2020-01-12 12:58 Saga Musix Note Added: 0004191
2020-01-12 13:04 Saga Musix Note Edited: 0004191 View Revisions
2020-01-12 14:44 Saga Musix Relationship added related to 0001291