View Issue Details

IDProjectCategoryView StatusLast Update
0001012OpenMPTPlugins / VSTpublic2020-01-12 14:44
ReporterFekinox Assigned To 
PrioritylowSeveritycrashReproducibilityalways
Status closedResolutionno change required 
Platformx64OSWindows 
Product VersionOpenMPT 1.26.14.00 / libopenmpt 0.2-beta27 (upgrade first) 
Summary0001012: VST SignalAnalyzer causes crash when opened
Description

Attempting to edit the VST SignalAnalyzer ( http://www.rs-met.com/freebies.html ) crashes OpenMPT with the description:

Unhandled exception 0xC0000005 at address 00000000 occured.

Steps To Reproduce
  1. Load the VST, then attempt to view it.
TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

related to 0001291 new Separate plugin bridge versions for legacy / buggy plugins 
has duplicate 0001290 closed Crash files from when opening Channel Matrix 2x2 plugin window 

Activities

Fekinox

Fekinox

2017-08-15 03:18

reporter  

crash files.zip (32,721 bytes)
Fekinox

Fekinox

2017-08-15 03:18

reporter   ~0003170

Oh yeah, I should also probably provide the debug information here...

Saga Musix

Saga Musix

2017-08-15 10:33

administrator   ~0003171

Seems to be a problem specific to Windows 10, and setting OpenMPT to run in Windows 8 compatibility mode prevents it from crashing. Interestingly the plugin doesn't crash in VSTHost or MadTracker, most likely because those two do not declare to be compatible with Windows 10. I am tempted to say this plugin is simply not compatible with Windows 10.

Saga Musix

Saga Musix

2017-08-15 10:39

administrator   ~0003172

Just confirmed: If I manually update MadTracker's manifest to declare Windows 10 compatibility, the plugin also stops working in MadTracker.
So this is a plugin issue, and you will have to ask the plugin author to fix it instead. Given that the plugin was last updated in 2008, I wouldn't get my hopes too high, though.
You can work around the issue by running OpenMPT in Windows 8 compatibility mode but I really would not recommend doing that, since it might have implications for other plugins and OpenMPT itself as well.

Saga Musix

Saga Musix

2017-08-15 10:43

administrator   ~0003173

Last edited: 2017-08-15 10:43

View 2 revisions

Another possible workaround which should not impact other plugins would be to force the plugin to run in OpenMPT's plugin bridge and then only set the compatibility settings for PluginBridge32.exe to Windows 8.
The better workaround is still to find an up-to-date and maintained plugin, though.

Issue History

Date Modified Username Field Change
2017-08-15 03:11 Fekinox New Issue
2017-08-15 03:18 Fekinox File Added: crash files.zip
2017-08-15 03:18 Fekinox Note Added: 0003170
2017-08-15 10:33 Saga Musix Note Added: 0003171
2017-08-15 10:39 Saga Musix Status new => closed
2017-08-15 10:39 Saga Musix Resolution open => no change required
2017-08-15 10:39 Saga Musix Note Added: 0003172
2017-08-15 10:43 Saga Musix Note Added: 0003173
2017-08-15 10:43 Saga Musix Note Edited: 0003173 View Revisions
2020-01-12 12:58 Saga Musix Relationship added has duplicate 0001290
2020-01-12 14:44 Saga Musix Relationship added related to 0001291