View Issue Details

IDProjectCategoryView StatusLast Update
0001283OpenMPTPlayback Compatibilitypublic2019-11-29 08:07
ReporterEssem Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindows 
Product VersionOpenMPT 1.28.08.00 / libopenmpt 0.4.9 (current stable) 
Target VersionOpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upcoming stable)Fixed in VersionOpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upcoming stable) 
Summary0001283: Incorrect volume in specific mod file
Description

At the beginning of pattern 0 of the attached mod file (aliceoncopper.mod) in channel 1, there's a segment where it specifies the instrument before it plays. There is also a note retrigger command at position 11 and a volume change effect at position 10. However, when trying to play this from the start, it seems to ignore the volume change effect entirely and play it much louder than intended. Strangely, however, when the pattern plays after the module loops, it plays this section as intended. This issue does not exist in other players such as XMPlay, MilkyTracker, or Extended Module Player.

Steps To Reproduce
  1. Load module
  2. Play from beginning
TagsNo tags attached.
Has the bug occurred in previous versions?Yes
Tested code revision (in case you know it)

Relationships

duplicate of 0001275 resolvedSaga Musix Playback problem with Captain - Beyond music - strange noise in the beginning 

Activities

Essem

Essem

2019-11-29 02:32

reporter  

aliceoncopper.7z (149,508 bytes)
Saga Musix

Saga Musix

2019-11-29 08:06

administrator   ~0004159

Luckily this was just fixed for the upcoming release in 0001275.

Issue History

Date Modified Username Field Change
2019-11-29 02:32 Essem New Issue
2019-11-29 02:32 Essem File Added: aliceoncopper.7z
2019-11-29 02:33 Essem Reproducibility sometimes => always
2019-11-29 08:06 Saga Musix Relationship added duplicate of 0001275
2019-11-29 08:06 Saga Musix Note Added: 0004159
2019-11-29 08:07 Saga Musix Status new => resolved
2019-11-29 08:07 Saga Musix Resolution open => fixed
2019-11-29 08:07 Saga Musix Fixed in Version => OpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upcoming stable)
2019-11-29 08:07 Saga Musix Target Version => OpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upcoming stable)