View Issue Details

IDProjectCategoryView StatusLast Update
0001275OpenMPT[All Projects] libopenmptpublic2019-11-01 15:18
ReporterSajadi Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version8
Product VersionOpenMPT 1.28.08.00 / libopenmpt 0.4.9 (current stable) 
Target VersionOpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upcoming stable)Fixed in VersionOpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upcoming stable) 
Summary0001275: Playback problem with Captain - Beyond music - strange noise in the beginning
Description

Seems there is a small bug with playback in version 0.4.9 and 0.5.0 of libopenmpt plugin.

For example if you start the track Beyond music from Captain
http://amp.dascene.net/downmod.php?index=12661

you can hear a strange "boink" sound in the beginning which was not present in the earlier old stable version 0.3.19

The playback of the old stable seems to be correct in this case.

Steps To Reproduce

1) Use Libopenmpt XMPLAY plugin versions 0.4.9 or 0.5.0 with Captain - Beyond music

2) Start the song

3) You hear strange noise at songstart which is not present with old stable 0.3.19

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2019-10-27 18:22

administrator   ~0004123

Should be fixed by r12249 in 0.5, might backport this to 0.4 if it doesn't break anything else.

Saga Musix

Saga Musix

2019-11-01 15:18

administrator   ~0004129

Backported to 0.4 in r12286.

Issue History

Date Modified Username Field Change
2019-10-27 17:38 Sajadi New Issue
2019-10-27 17:38 Sajadi File Added: MOD.beyond music.gz
2019-10-27 18:20 Saga Musix Assigned To => Saga Musix
2019-10-27 18:20 Saga Musix Status new => assigned
2019-10-27 18:20 Saga Musix File Deleted: MOD.beyond music.gz
2019-10-27 18:22 Saga Musix Note Added: 0004123
2019-10-27 18:23 Saga Musix Status assigned => feedback
2019-11-01 15:18 Saga Musix Note Added: 0004129
2019-11-01 15:18 Saga Musix Status feedback => resolved
2019-11-01 15:18 Saga Musix Resolution open => fixed
2019-11-01 15:18 Saga Musix Fixed in Version => OpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upcoming stable)
2019-11-01 15:18 Saga Musix Target Version => OpenMPT 1.28.09.00 / libopenmpt 0.4.11 (upcoming stable)