View Issue Details

IDProjectCategoryView StatusLast Update
0001267OpenMPT[All Projects] Plugins / VSTpublic2019-10-02 18:17
ReporterEatMe Assigned To 
PrioritynormalSeveritycrashReproducibilityunable to reproduce
Status closedResolutionduplicate 
Platformx64OSWindowsOS Version10
Product Version 
Target VersionFixed in Version 
Summary0001267: Crash on playing pattern (VSTi: Mausynth)
Description

I have tried to reproduce the bug, but was unable to.

I first played on my MIDI keyboard, then entered 8 notes in the first channel of the first (0) Pattern.
When I pushed play in the Pattern editor, ModPlug crashed with hanging (short buffer repeated) sound.

When playing with Mausynth ( http://rinki.net/pekka/mausynth/ ) , the steel UI.

Steps To Reproduce

Unable to reproduce yet

Additional Information

Windows x64 10, latest up to date version,
using the Plugin Bridge of the latest OpenMPT Alpha 1.29.00.31

TagsNo tags attached.
Has the bug occurred in previous versions?Don't know
Tested code revision (in case you know it)No idea

Relationships

duplicate of 0001116 acknowledgedmanx ASIO assertion failures 
has duplicate 0001268 closed Crashed on Mausynth VSTi 

Activities

EatMe

EatMe

2019-10-02 17:57

reporter  

2019-10-02 03.54.54 OpenMPT crash files.zip (33,586 bytes)
Saga Musix

Saga Musix

2019-10-02 18:02

administrator   ~0004099

using the Plugin Bridge of the latest OpenMPT Alpha 1.29.00.31

According to the crash dump you are not using the plugin bridge. If you were using the bridge, OpenMPT wouldn't crash but the bridge process would.

Saga Musix

Saga Musix

2019-10-02 18:08

administrator   ~0004100

Last edited: 2019-10-02 18:10

View 2 revisions

This is not an issue with a plugin but with your ASIO driver (duplicate of 0001116).

Internal error occurred at C:\Users\manx\projects\openmpt\buildbot\g2_trunk_dist_trk_win\build\mptrack\MainFrm.cpp(704): ASSERT(m_pSndFile != nullptr) failed in [SoundSourceUnlock].

Issue History

Date Modified Username Field Change
2019-10-02 17:57 EatMe New Issue
2019-10-02 17:57 EatMe File Added: 2019-10-02 03.54.54 OpenMPT crash files.zip
2019-10-02 18:02 Saga Musix Note Added: 0004099
2019-10-02 18:08 Saga Musix Note Added: 0004100
2019-10-02 18:08 Saga Musix Relationship added duplicate of 0001116
2019-10-02 18:09 Saga Musix Status new => closed
2019-10-02 18:09 Saga Musix Resolution open => duplicate
2019-10-02 18:09 Saga Musix Description Updated View Revisions
2019-10-02 18:09 Saga Musix Additional Information Updated View Revisions
2019-10-02 18:10 Saga Musix Note Edited: 0004100 View Revisions
2019-10-02 18:17 Saga Musix Relationship added has duplicate 0001268