View Issue Details

IDProjectCategoryView StatusLast Update
0001243OpenMPT[All Projects] File Format Supportpublic2019-08-09 20:47
ReporterGooseAssigned To 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionno change required 
Platformx86OSWindowsOS Version10
Product VersionOpenMPT 1.28.04.00 / libopenmpt 0.4.4 (upgrade first) 
Target VersionFixed in Version 
Summary0001243: When exported to MIDI, notes that would normally finish at the end of a bar are not cut off and continue until the end.
Description

I exported 8-bit Kids with Dreams by Skyline (.it) into a MIDI file. There are long notes that last until the end of each bar. When exporting this to a MIDI, the notes do not cut off at the end of the bar and instead all last until the end of the MIDI file, overlapping each other.

Steps To Reproduce

Export a .it with notes that finish at the end of each bar as a MIDI file.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2019-08-09 06:39

administrator   ~0003988

Can you please provide a link to the module in question?

Note: If a sampled note dies "naturally" (i.e. there is no explicit note-off event and the sample just reaches its end), then there is no way for the MIDI export to know that. It will just keep playing the note until there is a note-off or another note. on the same channel (assuming NNA is not set to "continue"). Given that note-off works in general, maybe this is what is happening here.

StarWolf3000

StarWolf3000

2019-08-09 10:52

reporter   ~0003989

Should be this one: https://modland.ziphoid.com/pub/modules/Impulsetracker/Skyline/8-bit%20kids%20with%20dreams.it

Saga Musix

Saga Musix

2019-08-09 17:31

administrator   ~0003990

So yeah, the chord instrument has NNA=Continue. It might be possible to send a note-off once the volume envelope reaches its end, but apart from that, in general case, there is little that can be done here.

Saga Musix

Saga Musix

2019-08-09 20:14

administrator   ~0003991

As a workaround, set the New Note Action of instrument to anything but "Continue" for MIDI export. You cannot expect MIDI conversions of just about any module to sound correct because there are just too many differences between module land and MIDI land, and this is one of them.

Saga Musix

Saga Musix

2019-08-09 20:46

administrator   ~0003992

I had a closer look at the export code again and decided that trying to "fix" this would make the export more complex than it should be. As mentioned above, there is a reason why this happens, and there is a workaround that you can use for exporting this module without troubles. Hence I'm going to close this issue.

Issue History

Date Modified Username Field Change
2019-08-08 22:02 Goose New Issue
2019-08-09 06:39 Saga Musix Note Added: 0003988
2019-08-09 06:40 Saga Musix Severity major => minor
2019-08-09 10:52 StarWolf3000 Note Added: 0003989
2019-08-09 17:31 Saga Musix Note Added: 0003990
2019-08-09 20:14 Saga Musix Note Added: 0003991
2019-08-09 20:46 Saga Musix Note Added: 0003992
2019-08-09 20:47 Saga Musix Status new => closed
2019-08-09 20:47 Saga Musix Resolution open => no change required