View Issue Details

IDProjectCategoryView StatusLast Update
0001169OpenMPT[All Projects] Generalpublic2018-11-25 14:27
ReportersincxAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.28.00.* (current testing) 
Target VersionOpenMPT 1.28.01.00 (goals)Fixed in VersionOpenMPT 1.28.01.00 (goals) 
Summary0001169: too easy to accidentally slice samples (seems unintentional but not sure)
Description

It's unclear to me whether this is intentional behavior or not but whatever the case it's very annoying. In the sample editor if I right click and then press the A key, or right click while already holding the A key, the sample gets sliced automatically, which happens far too often by accident and is painful to clean up, especially if it happens over and over again. If that behavior is intentional a confirmation dialog would at least be appreciated, though it's very unintuitive behavior if it actually is intentional.

Steps To Reproduce

right click and press A key, or hold A key and right click

TagsNo tags attached.
Has the bug occurred in previous versions?unsure but probably
Tested code revision (in case you know it)

Activities

StarWolf3000

StarWolf3000

2018-11-22 06:42

reporter   ~0003727

I don't actually get your problem here. Why would you want to right-click on the sample waveform and then press A (or the other way around), if not for speeding up sample editing? If you right-click, the context menu opens, and if there's an entry, where the key you're pressing is <u>underlined</u>, then this command is executed.

sincx

sincx

2018-11-22 07:32

reporter   ~0003728

it happens all the time when playing back samples, especially trying to set loop points. the A key is C so of course it's going to be one of the default ones i use for playing back samples, and the slightest overlap between playing a sample with A and right clicking to set a loop point or even jsut right clicking accidentally slices the sample. also there's nothing underlined so idk what youre getting at with that

Saga Musix

Saga Musix

2018-11-22 08:12

administrator   ~0003729

It is intentional that "A" is an accelerator key in the context menu, but it is of course not intentional that it makes a destructive action very easy to reach. I might just remove the accelerator altogether.

Side note on your last sentence: On "modern" Windows (since 7 or Vista?) accelerator keys are not underlined by default when the mouse is used to open a menu. In the control panel you can still tell Windows to always underline accelerator keys, which is what I personally prefer.

Saga Musix

Saga Musix

2018-11-25 14:27

administrator   ~0003742

I removed the accelerator key in r10994.

Issue History

Date Modified Username Field Change
2018-11-22 05:00 sincx New Issue
2018-11-22 06:42 StarWolf3000 Note Added: 0003727
2018-11-22 07:32 sincx Note Added: 0003728
2018-11-22 08:12 Saga Musix Note Added: 0003729
2018-11-22 08:12 Saga Musix Assigned To => Saga Musix
2018-11-22 08:12 Saga Musix Status new => assigned
2018-11-25 14:27 Saga Musix Note Added: 0003742
2018-11-25 14:27 Saga Musix Status assigned => resolved
2018-11-25 14:27 Saga Musix Resolution open => fixed
2018-11-25 14:27 Saga Musix Fixed in Version => OpenMPT 1.28.01.00 (goals)
2018-11-25 14:27 Saga Musix Target Version => OpenMPT 1.28.01.00 (goals)