View Issue Details

IDProjectCategoryView StatusLast Update
0001069OpenMPTUser Interfacepublic2020-01-17 21:23
ReporterVinCMG Assigned ToSaga Musix  
PrioritylowSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
Platformx86 / x64OSWine x64OS Version2.0.1
Product VersionOpenMPT 1.27.02.00 / libopenmpt 0.3.2/0.3.3 (upgrade first) 
Target VersionOpenMPT 1.29.01.00 / libopenmpt 0.5.0 (current stable)Fixed in VersionOpenMPT 1.29.01.00 / libopenmpt 0.5.0 (current stable) 
Summary0001069: Channel status display in bottom taskbar does not update when cycling backwards through channels
Description

When cycling right-to-left through channels using the Shift-Tab keybinding in the pattern editor, the text box at the bottom that displays the currently selected channel's number, volume, macro, filter, and pan settings is not updated. Cycling through channels left-to-right with Tab works fine.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2017-12-01 12:50

administrator   ~0003370

Hm, I guess that's because of the overlap of Shift+Tab being both used for backwards-cycling but Shift also being the selection key by default... and making a selection does not update the status bar. Tricky...

Saga Musix

Saga Musix

2020-01-17 21:23

administrator   ~0004194

I've fixed it the easy way now by updating the status bar also while making a selection.

Issue History

Date Modified Username Field Change
2017-12-01 11:31 VinCMG New Issue
2017-12-01 12:50 Saga Musix Note Added: 0003370
2020-01-17 21:23 Saga Musix Note Added: 0004194
2020-01-17 21:23 Saga Musix Assigned To => Saga Musix
2020-01-17 21:23 Saga Musix Status new => resolved
2020-01-17 21:23 Saga Musix Resolution open => fixed
2020-01-17 21:23 Saga Musix Fixed in Version => OpenMPT 1.29.01.00 / libopenmpt 0.5.0 (current stable)
2020-01-17 21:23 Saga Musix Target Version => OpenMPT 1.29.01.00 / libopenmpt 0.5.0 (current stable)