View Issue Details

IDProjectCategoryView StatusLast Update
0000994OpenMPT[All Projects] Plugins / VSTpublic2017-07-24 11:37
Reporterpigdevil2010 Assigned To 
PrioritynormalSeveritycrashReproducibilityrandom
Status closedResolutionduplicate 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.26.12.00 / libopenmpt 0.2-beta26 (upgrade first) 
Target VersionFixed in Version 
Summary0000994: Crash when trying to mute a MIDI output
Description

MIDI Input Output plugin is very unstable and very likely to crash when I stop the playback or mute the channel. Here is one example.

Unhandled exception 0xC0000005 at address 00007FFAD5442579 occurred.

Debug information has been saved to
C:\Users\P-Bot\AppData\Local\Temp\OpenMPT Crash Files\2017-07-24 12.20.26\

1 modified file has been rescued, but it cannot be guaranteed that it is still intact.

OpenMPT 1.26.12.00 64 bit ( (clean))

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

duplicate of 0000843 resolvedSaga Musix Sporadic deadlocks in MIDI I/O 

Activities

pigdevil2010

pigdevil2010

2017-07-24 05:37

reporter  

2017-07-24 12.20.26.zip (468,507 bytes)
Saga Musix

Saga Musix

2017-07-24 11:37

administrator   ~0003114

PortMidi is somewhat buggy so we switched to a new MIDI I/O library (RtMidi) for OpenMPT 1.27. Backporting all those changes to OpenMPT 1.26 is out of scope though, so you will have to obtain a current test build from https://builds.openmpt.org/builds/ for now. Those shouldn't crash anymore.

Issue History

Date Modified Username Field Change
2017-07-24 05:37 pigdevil2010 New Issue
2017-07-24 05:37 pigdevil2010 File Added: 2017-07-24 12.20.26.zip
2017-07-24 11:37 Saga Musix Status new => closed
2017-07-24 11:37 Saga Musix Resolution open => duplicate
2017-07-24 11:37 Saga Musix Note Added: 0003114
2017-07-24 11:37 Saga Musix Relationship added duplicate of 0000843