View Issue Details

IDProjectCategoryView StatusLast Update
0000924OpenMPT[All Projects] Feature Requestpublic2017-03-11 12:20
ReporterLupineDreamAssigned To 
PrioritylowSeverityfeatureReproducibilityN/A
Status closedResolutionwon't fix 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.26.08.00 / libopenmpt 0.2-beta20.5 (upgrade first) 
Target VersionFixed in Version 
Summary0000924: Standalone instrument editor
Description

The editor inside the application is indeed nice and fully functional. But in the case of building a large project, would it be feasable to create a standalone instrument editor application? This application could contain features such as:

Soundfont imports
Sample editor
Eidt sample in... (options for Audacity, other open source softwares via Windows API)
VST wrapper
Instrument libraries
Configuration paths for instrument libraries
SimpleSQL, gzip sample-packed format importable instrument packs via "Build pack..." option
Fullscreen GUI focusing soley on creating instruments targeted at specific hardware (or just fun ones)
Instrument types:
Scratch pad (testing)
MPC pad (testing)
MIDI keyboard (testing)
MIDI mapping for instrument types
Source hardware ini or cfg presets (or:)
SimpleSQL format supported hardware database + MIDI Mapping (also for main application)
Destination hardware ini or cfg presets (or:)
SimpleSQL format supported hardware database + IRQ/seg:offs and register mapping (optional) (also for main application, makes stuff work for Gravis Ultrasound, Tandy, Adlib, etc...)
Graphical ADSR for sample loops (same as main application)
Mathematical ADSR (percise control of ADSR ramps based on hardware presets: CM64, Atari, SBLive, NES, etc.), (no more tweaking to get it working right on specific platform, always hear it as-is on destination hardware)
Echo and reverb presets based on hardware presets (...)

Target goal:

Release and let the open source community build their own favorite hardware presets.
Build a community on emulating the sound of retro hardware ( a lot of people use OpenMPT for this type of project ). Development of instrument and platform editor builds knowledge and adaptability of many different (and possibly rare) hardware platforms.
End user recieves thrilling learning experience about the development and arcitechture of retro hardwares and more actively engages with OpenMPT.
Easy import into main application with minimal changes due to being a module instead of the main application.
Still able to tweak instrument packs in main app to preference.
Have fun playing sounds as if they where being played through the real thing.

Tagsinstrument, requests
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2017-03-11 12:19

administrator   ~0002906

Sorry, but this is completely out of scope for the OpenMPT project. Anyone is welcome to use the instrument editing code under the BSD license for their own projects of course, but this is nothing that we OpenMPT developers have time for.

Issue History

Date Modified Username Field Change
2017-03-11 04:09 LupineDream New Issue
2017-03-11 04:09 LupineDream Tag Attached: instrument
2017-03-11 04:09 LupineDream Tag Attached: requests
2017-03-11 12:19 Saga Musix Note Added: 0002906
2017-03-11 12:20 Saga Musix Status new => closed
2017-03-11 12:20 Saga Musix Resolution open => won't fix