View Issue Details

IDProjectCategoryView StatusLast Update
0000092OpenMPT[All Projects] Feature Requestpublic2011-04-01 17:08
ReporterharbingerAssigned ToSaga Musix 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product VersionOpenMPT 1.18.03.00 (upgrade first) 
Target VersionOpenMPT 1.19.01.00 (upgrade first)Fixed in VersionOpenMPT 1.19.01.00 (upgrade first) 
Summary0000092: Filter Mode Status
Description

When switching filter modes in a channel, one can quickly lose track of which mode the channel is in -- Hi-Pass or Lo-Pass. What would be helpful is an indicator in the Status Bar (before the Cutoff marker, preferably) to show the last Filter Mode that was called, which would be either "FM=LP" or "FM=HP", for the channel where the cursor exists.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2011-03-22 22:21

administrator   ~0000109

To save some space, I'd suggest to change the Cutoff field to say something like "Cut:7F-Hi" if the highpass filter mode is set.

Saga Musix

Saga Musix

2011-03-23 20:58

administrator   ~0000110

Revision 826 adds a filter indication to the status bar.

harbinger

harbinger

2011-03-25 18:59

reporter   ~0000111

Thanks, Jojo. I knew this would be the easiest of all my other requests. Can you provide the link for the test run (if you'd like feedback)? Or otherwise email me a copy of the test EXE?

Saga Musix

Saga Musix

2011-03-25 19:00

administrator   ~0000112

Same link as always: http://sagagames.de/stuff/mptrack.exe

harbinger

harbinger

2011-03-29 20:38

reporter   ~0000119

1.19.00.30

After testing by setting both 8-bit macros (00-7F)as well as 16-bit macros (80-FF) to Filter Mode, both together and separately, the Status Bar indeed indicates a HiPass mode with "Cut: x-Hi". with x representing the current low-bit value (such as the default cutoff assignment). I would prefer this indication stand out a little more, esp. since all the type looks like 9 pt. throughout the Status Bar (and is nearly washed out in an 1152x864 monitor), but it indeed works based on the current channel's filter mode.

Just a note. You can call this "resolved" again.

Issue History

Date Modified Username Field Change
2011-03-22 20:49 harbinger New Issue
2011-03-22 22:18 Saga Musix Assigned To => Saga Musix
2011-03-22 22:18 Saga Musix Status new => assigned
2011-03-22 22:21 Saga Musix Note Added: 0000109
2011-03-23 20:58 Saga Musix Note Added: 0000110
2011-03-23 22:44 Saga Musix Status assigned => feedback
2011-03-23 22:44 Saga Musix Fixed in Version => OpenMPT 1.19.00.* (old testing)
2011-03-23 22:44 Saga Musix Target Version => OpenMPT 1.19.01.00 (upgrade first)
2011-03-25 18:59 harbinger Note Added: 0000111
2011-03-25 18:59 harbinger Status feedback => assigned
2011-03-25 19:00 Saga Musix Note Added: 0000112
2011-03-25 19:20 Saga Musix Status assigned => resolved
2011-03-25 19:20 Saga Musix Resolution open => fixed
2011-03-29 20:38 harbinger Note Added: 0000119
2011-03-29 20:38 harbinger Status resolved => feedback
2011-03-29 20:38 harbinger Resolution fixed => reopened
2011-04-01 17:00 Saga Musix Status feedback => resolved
2011-04-01 17:00 Saga Musix Resolution reopened => fixed
2011-04-01 17:00 Saga Musix Target Version OpenMPT 1.19.01.00 (upgrade first) => OpenMPT 1.19.00.* (old testing)
2011-04-01 17:08 Saga Musix Target Version OpenMPT 1.19.00.* (old testing) => OpenMPT 1.19.01.00 (upgrade first)