View Issue Details

IDProjectCategoryView StatusLast Update
0000091OpenMPTFeature Requestpublic2015-04-20 19:43
Reporterharbinger Assigned ToSaga Musix  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product VersionOpenMPT 1.18.03.00 (upgrade first) 
Target VersionOpenMPT 1.24.03.00 / libopenmpt 0.2-beta11 (upgrade first)Fixed in VersionOpenMPT 1.24.03.00 / libopenmpt 0.2-beta11 (upgrade first) 
Summary0000091: Better offset handling in Note FX
Description

One of MPT's limitations with offsets is that you can't for example retrigger (with Qxx) from an offset if the waveform is too long. The volume column has the added ability to apply an offset with the oxx command, but it's really only useful for low-bit or extremely short samples. I propose a new way to handle these.
Since the value is limited to o01 - o09, the value should represent a PERCENTAGE within the entire waveform to begin playing. Perhaps the value should be allowed to go up to 99 for finer detail. To help determine WHERE in the waveform the oxx command would be applied, i would suggest a marker in the Status Bar on the Sample page that gives the information of where the cursor lies within the Sample window, much like is done for Oxx and SAx.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

related to 0000659 resolvedSaga Musix Add timestamp ruler to sample view 

Activities

Saga Musix

Saga Musix

2011-03-22 21:01

administrator   ~0000102

It is not possible to extend the volume column with more commands or more precise commands (well, there are a few dozen possible values left, but I'd prefer not to touch them without a good reason). In fact I have been juggling with the idea of assigning cue points to samples, which then could be called with the volume column's oxx command - o01 would jump to the first cue point, o02 to the second and so on.

harbinger

harbinger

2011-03-22 22:03

reporter   ~0000106

Ooo, i like that idea. After all, we generally know where in the sample we need to offset to (as opposed to offsetting to some random or unknown point), so this would be a PERFECT solution. This would actually be more amenable than my suggestion of reconfiguring an older command (which could "decompatibilize" older tracks that use it).

Wow, if you could somehow implement this, we will both be using this alot. ;)

Saga Musix

Saga Musix

2015-03-11 14:26

administrator   ~0001980

Last edited: 2015-03-11 14:26

View 2 revisions

r4862 (soon available on http://buildbot.openmpt.org/builds/auto/openmpt-win32/ as always) implements sample cue points. Currently they work like this: In the sample tab, right-click the point where you want to set a cue, then choose from the context menu which cue you want to set. Then, use the volume column o command to use this cue. The default cues are compatible to the previous command behaviour.

It's obvious that the current implementation is not perfect yet, especially since you cannot actually see the sample cues in the editor. The related issue 0000659 should fix this usability issue.

harbinger

harbinger

2015-04-20 19:39

reporter   ~0002038

Works great, mostly intuitive, but the only thing missing is the line to show the cue points (maybe with the oxx value at the top). It would be great if the cue line was of a different color.

Re-opening to add on this last feature...

Saga Musix

Saga Musix

2015-04-20 19:43

administrator   ~0002039

No need to reopen and cram everything into one ticket, see the relate issue instead. That's exactly what you want.

Issue History

Date Modified Username Field Change
2011-03-22 20:48 harbinger New Issue
2011-03-22 21:01 Saga Musix Note Added: 0000102
2011-03-22 22:03 harbinger Note Added: 0000106
2015-03-10 23:53 Saga Musix Assigned To => Saga Musix
2015-03-10 23:53 Saga Musix Status new => assigned
2015-03-10 23:53 Saga Musix Target Version => OpenMPT 1.24.03.00 / libopenmpt 0.2-beta11 (upgrade first)
2015-03-11 14:24 Saga Musix Relationship added related to 0000659
2015-03-11 14:26 Saga Musix Note Added: 0001980
2015-03-11 14:26 Saga Musix Status assigned => feedback
2015-03-11 14:26 Saga Musix Note Edited: 0001980 View Revisions
2015-04-18 16:29 Saga Musix Status feedback => resolved
2015-04-18 16:29 Saga Musix Resolution open => fixed
2015-04-18 16:29 Saga Musix Fixed in Version => OpenMPT 1.24.03.00 / libopenmpt 0.2-beta11 (upgrade first)
2015-04-20 19:39 harbinger Note Added: 0002038
2015-04-20 19:39 harbinger Status resolved => feedback
2015-04-20 19:39 harbinger Resolution fixed => reopened
2015-04-20 19:43 Saga Musix Note Added: 0002039
2015-04-20 19:43 Saga Musix Status feedback => resolved
2015-04-20 19:43 Saga Musix Resolution reopened => fixed