View Issue Details

IDProjectCategoryView StatusLast Update
0000864OpenMPT[All Projects] File Format Supportpublic2017-08-02 20:09
ReporterDiamondAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.27.00.* (old testing) 
Target VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (current stable)Fixed in VersionOpenMPT 1.27.01.00 / libopenmpt 0.3.1 (current stable) 
Summary0000864: Direct access to "Swing Settings" dialog
Description

It would be nice to have a command/assignable shortcut for directly accessing the "Tempo Swing Settings" dialog.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2016-08-16 11:55

administrator   ~0002606

But how would it work? Would it always open the global swing settings? Would it open the per-pattern swing settings when the pattern editor is focussed?

Diamond

Diamond

2016-08-16 12:50

reporter   ~0002607

I didn't think of that. Perhaps it might be easier to just have separate commands/key bindings for each one?

Diamond

Diamond

2016-08-16 13:27

reporter   ~0002608

In the case of the per-pattern swing settings, I suppose it might also make sense to enable the "Override song signature" checkbox if you select "OK" after making changes.

Saga Musix

Saga Musix

2016-08-18 12:40

administrator   ~0002613

In the case of the per-pattern swing settings, I suppose it might also make sense to enable the "Override song signature" checkbox if you select "OK" after making changes.

That's backwards, because you first need to enable "Override song signature" before you can actually edit the per-pattern swing settings. Or were you able to edit them without checking the override box first?

Diamond

Diamond

2016-08-18 12:54

reporter   ~0002614

It is backwards and no I was not able to access them without checking the override box, but you asked how this would work and I was just contemplating some way you could have a command to access the per-pattern settings directly since normally the checkbox has to be enabled first as you say.

Saga Musix

Saga Musix

2016-08-18 12:58

administrator   ~0002615

My idea is currently to let the shortcut always open the global swing settings.
Rationale: When modifying these settings, you are most likely already in the pattern editor, so you could almost never reach the global swing settings reasonably using this shortcut. Per-pattern swing settings can already be reached through another shortcut (Pattern Properties).

An alternative solution would be to open the global settings if the currently edited pattern doesn't have per-pattern swing settings yet (or if the user is not in the pattern editor), and open the per-pattern settings otherwise. However, I am not sure if this is more or less confusing that the first proposal.

Diamond

Diamond

2016-08-18 13:14

reporter   ~0002616

The second solution seems logical to me, but I can't speak for anyone else. Although my guess is that most tracker users are somewhat more technically inclined than the average user so it shouldn't be difficult to grasp.

Saga Musix

Saga Musix

2017-08-02 20:09

administrator   ~0003128

r8692 adds a new shortcut, "View Global Tempo Swing Settings". If modern tempo mode is not activated yet, it will warn the user and open the song properties dialog instead.
For pattern-specific tempo swing, there is already the possibility of using the pattern properties shortcut, as discussed.

Issue History

Date Modified Username Field Change
2016-08-16 02:35 Diamond New Issue
2016-08-16 11:55 Saga Musix Note Added: 0002606
2016-08-16 12:50 Diamond Note Added: 0002607
2016-08-16 13:27 Diamond Note Added: 0002608
2016-08-18 12:40 Saga Musix Note Added: 0002613
2016-08-18 12:54 Diamond Note Added: 0002614
2016-08-18 12:58 Saga Musix Note Added: 0002615
2016-08-18 13:14 Diamond Note Added: 0002616
2017-08-02 20:09 Saga Musix Assigned To => Saga Musix
2017-08-02 20:09 Saga Musix Status new => resolved
2017-08-02 20:09 Saga Musix Resolution open => fixed
2017-08-02 20:09 Saga Musix Fixed in Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (current stable)
2017-08-02 20:09 Saga Musix Target Version => OpenMPT 1.27.01.00 / libopenmpt 0.3.1 (current stable)
2017-08-02 20:09 Saga Musix Note Added: 0003128