View Issue Details

IDProjectCategoryView StatusLast Update
0000081OpenMPT[All Projects] Feature Requestpublic2011-03-27 21:54
ReporterToXeyAssigned ToSaga Musix 
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product VersionOpenMPT 1.18.03.00 (upgrade first) 
Target VersionOpenMPT 1.19.01.00 (upgrade first)Fixed in VersionOpenMPT 1.19.01.00 (upgrade first) 
Summary0000081: The fade out value slider is too slow.
Description

The Fade Out value on the instruments tab cannot be set to values of 1000 to 8192 (maximum value), only values of 1 to 999.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2011-03-03 21:59

administrator   ~0000080

Can't reproduce that. I can enter any valid number in there and also use the spin wheel to increase / decrease the fadeout count.

jmkz

jmkz

2011-03-14 02:23

reporter   ~0000091

I guess what does ToXey means. Wait a moment for the explanation.

jmkz

jmkz

2011-03-14 02:39

reporter   ~0000092

Last edited: 2011-03-14 02:47

View 5 revisions

OpenMPT 1.18.2 doesn't have this bug.

Please watch example video:
https://sites.google.com/site/jmkzproductions/archivos/bug81.mov?attredirects=0&d=1 (AAC-MPEG4, 1.1MiB)

Tested Versions

1.17.02.54
1.17.03.02
1.18rc0
1.18.02
1.18.03

First four are excent of this bug, running under Windows XP SP3 x86 (not tested in other OS).

Saga Musix

Saga Musix

2011-03-14 16:51

administrator   ~0000093

That's exactly what I tried and I cannot reproduce it. Maybe it only happens on Windows XP and similar OSes, I'll check later...

jmkz

jmkz

2011-03-15 02:04

reporter   ~0000094

Ok. I have tested on more (4) computers with XP and have the same bug. I have downloaded a test version of VS2010 Pro and I will trace when this bug appears, since where a lot of time consuming for this bug :\

Saga Musix

Saga Musix

2011-03-15 08:59

administrator   ~0000095

Well, there is nothing to trace, I fear. It looks like a wrongly set property or a bug in MFC to me, but even changing the edit control from numeric to text doesn't help. SetLimitText has no effect at all.

Saga Musix

Saga Musix

2011-03-26 12:44

administrator   ~0000113

I kind of found out how to get rid of this broken behaviour now... I deleted the control completely and created a new one, and now the size limit is set correctly for me. Will be fixed in the next commit.

Saga Musix

Saga Musix

2011-03-26 13:14

administrator   ~0000114

Please check if http://sagagames.de/stuff/mptrack.exe fixes the problem for you.

jmkz

jmkz

2011-03-26 17:18

reporter   ~0000115

Last edited: 2011-03-26 17:21

View 2 revisions

I can confirm that this bug were corrected. Wait for ToXey confirmation?

ToXey

ToXey

2011-03-27 21:53

reporter   ~0000117

Yes, the bug was corrected with that one.

Issue History

Date Modified Username Field Change
2011-03-03 18:38 ToXey New Issue
2011-03-03 21:59 Saga Musix Note Added: 0000080
2011-03-14 02:23 jmkz Note Added: 0000091
2011-03-14 02:39 jmkz Note Added: 0000092
2011-03-14 02:39 jmkz Note Edited: 0000092 View Revisions
2011-03-14 02:40 jmkz Note Edited: 0000092 View Revisions
2011-03-14 02:46 jmkz Note Edited: 0000092 View Revisions
2011-03-14 02:47 jmkz Note Edited: 0000092 View Revisions
2011-03-14 16:51 Saga Musix Note Added: 0000093
2011-03-15 02:04 jmkz Note Added: 0000094
2011-03-15 08:59 Saga Musix Note Added: 0000095
2011-03-26 12:44 Saga Musix Note Added: 0000113
2011-03-26 13:14 Saga Musix Note Added: 0000114
2011-03-26 13:14 Saga Musix Assigned To => Saga Musix
2011-03-26 13:14 Saga Musix Status new => feedback
2011-03-26 13:14 Saga Musix Fixed in Version => OpenMPT 1.19.01.00 (upgrade first)
2011-03-26 13:14 Saga Musix Target Version => OpenMPT 1.19.00.* (old testing)
2011-03-26 13:16 Saga Musix Fixed in Version OpenMPT 1.19.01.00 (upgrade first) => OpenMPT 1.19.00.* (old testing)
2011-03-26 13:16 Saga Musix Target Version OpenMPT 1.19.00.* (old testing) => OpenMPT 1.19.01.00 (upgrade first)
2011-03-26 17:18 jmkz Note Added: 0000115
2011-03-26 17:21 jmkz Note Edited: 0000115 View Revisions
2011-03-27 21:53 ToXey Note Added: 0000117
2011-03-27 21:53 ToXey Status feedback => assigned
2011-03-27 21:54 Saga Musix Status assigned => resolved
2011-03-27 21:54 Saga Musix Resolution open => fixed