View Issue Details

IDProjectCategoryView StatusLast Update
0000079OpenMPTPlugins / VSTpublic2013-12-07 21:04
ReporterMaxime Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.18.03.00 (upgrade first) 
Target VersionOpenMPT 1.19.01.00 (upgrade first)Fixed in VersionOpenMPT 1.19.01.00 (upgrade first) 
Summary0000079: Exception in Dispatch(1) with E-MU EmulatorX/ProteusVX VST plugins
Description

I'm trying, after a long time working with OpenMPT without VSTi's, to enhance my music with higher quality instruments. I've bought Emulator X3 for this purpose, but it has some annoying flaws and strange behavior with OpenMPT:

  • the plugin editor window, once opened, can't be closed by clicking on the X button or from the plugin's menu bar (the plugin's menu bar is stuck).
    When closing OpenMPT with this plugin loaded, a message box appars, saying "Error while destroying plugin - Exception in Dispatch(1) (Plugin="EmulatorX")"

  • I used to notice some other bugs with this plugin but can't remember anything for the moment.

Steps To Reproduce

As E-MU Emulator X3 is a quite expensive piece of software, you can reproduce the EXACT same problems with Proteus VX, which is available for free from E-MU website:

  • Load Proteus VX/Emulator X3 into a free FX slot.
  • Bring the properties/edit window: you can't close it now, except by clicking on a button that opens the Plugin GUI window (eg. Editor button from the Instrument tab)
  • If you close OpenMPT with this plugin loaded, a message box appars, saying "Error while destroying plugin - Exception in Dispatch(1) (Plugin="EmulatorX")"
Additional Information

Please note that I've reproduced these problem on two extremely different platforms:

  • My home PC running Windows 7 x64, OpenMPT and Emulator X3 in 32-bit mode (as OpenMPT is 32), using one of my own soundbanks.
  • My portable MacBook Pro running Windows XP MCE through Parallels Desktop 4 virtualization software, OpenMPT and Proteus VX using one of the bundled soundbanks.

I know that Emulator X can be very buggy sometimes (crashes the host...) but this problem only arises with OpenMPT. No problem using it in the same conditions, with the same song, from REAPER (most stable DAW with this plugin), Renoise, SONAR...

TagsNo tags attached.
Has the bug occurred in previous versions?1.17.02.54
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2011-02-28 22:16

administrator   ~0000075

I for once can't reproduce the Dispatch problem... Does it happen to you if you just load the Plugin into a Module and then instantly close the module again?

Maxime

Maxime

2011-02-28 22:34

reporter   ~0000076

Thanks for your interest.

With v1.18.03, I can reproduce it quite easily:

  • create a new module (I use IT format in case it'd make a difference)
  • from the Select button near FX1:undefined combo on the main tab, select EmulatorX and Put in FX01
  • open the plugin window from the Edit button near Select
    -> from now on, I can't close the plugin window using the X button;
    -> and if I close OpenMPT's window, I have this error.

I haven't retried with ProteusVX yet.
But as far as I can remember, ProteusVX suffered from the same issue.

Saga Musix

Saga Musix

2011-02-28 22:38

administrator   ~0000077

Ok, so I guess one of the recent VST fixes has improved behaviour with those plugins as well, because I can reproduce the error with OpenMPT 1.18.03.00, but not with the latest test version. Can you confirm that there's no "Dispatch" error with http://sagagames.de/stuff/mptrack.exe ?

Maxime

Maxime

2011-03-01 05:51

reporter   ~0000078

Last edited: 2011-03-01 05:51

View 2 revisions

The Dispatch exception has effectively disappeared with this test version.

However, I still can't close the plugin window using the X button from the plugin editor window, or use the plugin menubar added by OpenMPT (the native plugin menubar seems to work). I'm forced to close the plugin GUI window using the Editor button I used to open it.

If you consider that these two problems should be treated as a separate issue, you can mark this one as solved, and I'll open a new ticket.

Saga Musix

Saga Musix

2011-03-01 12:13

administrator   ~0000079

Yes, to keep things tidy, this should be moved to a separate ticket.

Saga Musix

Saga Musix

2013-12-07 21:04

administrator   ~0001399

Since I don't think a separate issue has been created, I just wanted to add here that the issue with the broken plugin window and unusable X button is now resolved. The fix can be found in the latest test version, linked above.

Issue History

Date Modified Username Field Change
2011-02-28 06:21 Maxime New Issue
2011-02-28 22:16 Saga Musix Note Added: 0000075
2011-02-28 22:34 Maxime Note Added: 0000076
2011-02-28 22:38 Saga Musix Note Added: 0000077
2011-03-01 05:51 Maxime Note Added: 0000078
2011-03-01 05:51 Maxime Note Edited: 0000078 View Revisions
2011-03-01 12:13 Saga Musix Note Added: 0000079
2011-03-01 12:13 Saga Musix Status new => resolved
2011-03-01 12:13 Saga Musix Fixed in Version => OpenMPT 1.19.00.* (old testing)
2011-03-01 12:13 Saga Musix Resolution open => fixed
2011-03-01 12:13 Saga Musix Assigned To => Saga Musix
2011-03-01 13:38 Saga Musix Target Version => OpenMPT 1.19.01.00 (upgrade first)
2013-12-07 21:04 Saga Musix Note Added: 0001399
2016-11-20 17:48 Saga Musix Category VST => Plugins (VST)
2016-11-20 17:48 Saga Musix Category Plugins (VST) => Plugins / VST