View Issue Details

IDProjectCategoryView StatusLast Update
0000767OpenMPT[All Projects] Generalpublic2016-04-25 00:56
ReporterFarticus MaximusAssigned To 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Platformx86OSWindowsOS Version8
Product VersionOpenMPT 1.25.04.00 / libopenmpt 0.2-beta16 (upgrade first) 
Target VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)Fixed in VersionOpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first) 
Summary0000767: Soundfont Compatability
Description

Sometimes OpenMPT fails to transpose instrument samples, making the soundfont a clicky, high pitched noise.

Steps To Reproduce

*Only with some soundfonts
1.Import a soundfont as an instrument.

  1. Enter the data and the instrument will sound high pitched.
Additional Information

If you transpose the note to the 0th or 1st octave, it will sound fine.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

duplicate of 0000761 resolvedSaga Musix Sf2 import( and probably other too) doesn't set c5 speed properly 

Activities

Saga Musix

Saga Musix

2016-04-25 00:56

administrator   ~0002345

Already fixed for next stable version.

Issue History

Date Modified Username Field Change
2016-04-25 00:07 Farticus Maximus New Issue
2016-04-25 00:55 Saga Musix Relationship added duplicate of 0000761
2016-04-25 00:56 Saga Musix Note Added: 0002345
2016-04-25 00:56 Saga Musix Status new => closed
2016-04-25 00:56 Saga Musix Resolution open => duplicate
2016-04-25 00:56 Saga Musix Fixed in Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)
2016-04-25 00:56 Saga Musix Target Version => OpenMPT 1.26.01.00 / libopenmpt 0.2-beta17 (upgrade first)