View Issue Details

IDProjectCategoryView StatusLast Update
0000679OpenMPT[All Projects] Feature Requestpublic2016-04-16 14:50
Reporterharbinger Assigned ToSaga Musix  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Platformx86OSWindowsOS VersionXP
Product Version 
Target VersionFixed in Version 
Summary0000679: Soundfont Transposer
Description

When importing many soundfont instruments as a Modplug Instrument, the samples are often way out of transposition. I have to go back into each sample and transpose down one or two octaves just to be usable.

Perhaps ModPlug can make it easier. When dragging a soundfont instrument into ModPlug (to create an internal instrument with samples), a dialog can allow the user to preview each sample at the given octave, and allow for easy transposition BEFORE the samples are imported.

This would also have the side benefit of allowing a soundfont instrument to be previewed before setting up a Modplug Instrument.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

duplicate of 0000761 resolvedSaga Musix Sf2 import( and probably other too) doesn't set c5 speed properly 

Activities

Saga Musix

Saga Musix

2015-04-18 18:53

administrator   ~0002037

The correct way to fix this problem would be to import soundfonts with the correct pitch, not to work around it. I don't know why exactly some soundfont patches are imported at the wrong pitch though, I tried fixing it once but it didn't help.

Saga Musix

Saga Musix

2015-04-22 20:36

administrator   ~0002046

Besides, you can already just transpose the whole instrument through the sample map (at the expense of losing a proper assignment for the lowest and highest octaves), instead of transposing each sample on its own.

Saga Musix

Saga Musix

2016-04-16 14:50

administrator   ~0002334

Soundfonts should now be imported properly, see related issue 0000761.

Issue History

Date Modified Username Field Change
2015-04-18 18:30 harbinger New Issue
2015-04-18 18:53 Saga Musix Note Added: 0002037
2015-04-22 20:36 Saga Musix Note Added: 0002046
2016-04-16 14:50 Saga Musix Relationship added duplicate of 0000761
2016-04-16 14:50 Saga Musix Note Added: 0002334
2016-04-16 14:50 Saga Musix Status new => closed
2016-04-16 14:50 Saga Musix Assigned To => Saga Musix
2016-04-16 14:50 Saga Musix Resolution open => duplicate