View Issue Details

IDProjectCategoryView StatusLast Update
0000065OpenMPT[All Projects] User Interfacepublic2011-02-09 08:08
ReporterjmkzAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product VersionOpenMPT 1.18.03.00 (upgrade first) 
Target VersionOpenMPT 1.19.01.00 (upgrade first)Fixed in VersionOpenMPT 1.19.01.00 (upgrade first) 
Summary0000065: Renaming channel name in pattern editor doesn't set document as modified
Description

Renaming channel name in pattern editor doesn't set document as modified.

Steps To Reproduce
  1. Open or create a new module
  2. Go to pattern editorn and rename a channel.
    OpenMPT does not set document as modified.
Additional Information

Tested versions:

Current 1.18.3
Devel. builds:

1.19.0.22
1.18.2.0 (Build Date: Jun 6 2010 18:29:43)

TagsNo tags attached.
Has the bug occurred in previous versions?Yes, I think since were introduced "rename channel"
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2011-02-08 11:11

administrator   ~0000060

Revision 795 should fix this issue.

Issue History

Date Modified Username Field Change
2011-02-08 05:06 jmkz New Issue
2011-02-08 05:59 jmkz File Added: 3140734.png
2011-02-08 11:05 Saga Musix Assigned To => Saga Musix
2011-02-08 11:05 Saga Musix Status new => assigned
2011-02-08 11:11 Saga Musix Note Added: 0000060
2011-02-08 11:11 Saga Musix Status assigned => feedback
2011-02-08 11:11 Saga Musix Fixed in Version => OpenMPT 1.19.00.* (old testing)
2011-02-08 11:11 Saga Musix Target Version => OpenMPT 1.19.01.00 (upgrade first)
2011-02-08 18:37 Saga Musix File Deleted: 3140734.png
2011-02-09 03:57 jmkz Resolution open => fixed
2011-02-09 08:08 Saga Musix Status feedback => resolved