View Issue Details

IDProjectCategoryView StatusLast Update
0000006OpenMPT[All Projects] Playback Compatibilitypublic2010-11-07 16:27
ReporterSaga MusixAssigned ToSaga Musix 
PriorityhighSeveritymajorReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.18.03.00 (upgrade first) 
Target VersionOpenMPT 1.19.01.00 (upgrade first)Fixed in VersionOpenMPT 1.19.01.00 (upgrade first) 
Summary0000006: OpenMPT needs a mixmode that is compatible with legacy trackers
Description

None of the currently available mixmodes are actually suitable for playing back MOD/S3M/XM/IT. With Original/RC1/RC2 mixmodes, one has to depend on the pre-amp being set to a sane value. With the RC3 mixmode this is fixed, but it enforces soft panning, which alters the panning so much that modules made with RC3 will sound completely different in Impulse Tracker or XMPlay when using a lot of stereo effects.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2010-11-01 18:07

administrator   ~0000001

Last edited: 2010-11-01 19:46

View 2 revisions

At the moment, it looks like using mixmode RC3 as a base for this would be a good idea. The most noticable difference would be to force soft panning being disabled and slightly modified mix levels, but I have not found any good values yet. RC3 sounds a bit too loud to me. Shifting the volume levels by another bit seems to sound like what Schism does, though.

Saga Musix

Saga Musix

2010-11-05 23:09

administrator   ~0000002

SVN rev. 756 introduces a new mixmode which should have more appropriate mix levels for MOD/S3M/XM/IT.

Issue History

Date Modified Username Field Change
2010-10-31 21:49 Saga Musix New Issue
2010-10-31 21:49 Saga Musix Status new => assigned
2010-10-31 21:49 Saga Musix Assigned To => Saga Musix
2010-11-01 18:07 Saga Musix Note Added: 0000001
2010-11-01 19:46 Saga Musix Note Edited: 0000001 View Revisions
2010-11-01 22:04 Saga Musix Summary OpenMPT needs a mixmode that is compatible to legacy trackers => OpenMPT needs a mixmode that is compatible with legacy trackers
2010-11-05 23:09 Saga Musix Note Added: 0000002
2010-11-05 23:09 Saga Musix Resolution open => fixed
2010-11-05 23:10 Saga Musix Status assigned => resolved
2010-11-07 16:27 Saga Musix Fixed in Version => OpenMPT 1.19.00.* (old testing)