View Issue Details

IDProjectCategoryView StatusLast Update
0000056OpenMPT[All Projects] User Interfacepublic2011-04-04 22:11
ReporterharbingerAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSXPOS VersionSP3?
Product VersionOpenMPT 1.18.03.00 (upgrade first) 
Target VersionOpenMPT 1.19.01.00 (upgrade first)Fixed in VersionOpenMPT 1.19.01.00 (upgrade first) 
Summary0000056: Entries made by Note Properties dialog are not undo-able
Description

When entering notes or effects via the Note Properties dialog (opened by double-clicking a field in the Pattern Editor), the entry is not added to the Undo cache, and using the Undo function will bypass deletion of the entry. This of course is not desired behavior, but is rather minor since most entries are made by shortcut keys.

Steps To Reproduce

Double-click on a field in the Pattern Editor; this opens the Note Properties dialog. Select any note or effect to enter. Close the box or click in the Pattern Editor. Now execute an Undo via menu or shortcut key.
The entry is not deleted, but if there were other entries (not made in the same way), they will be un-done in normal regressive order...

TagsNo tags attached.
Has the bug occurred in previous versions?Not sure.
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2010-12-23 23:28

administrator   ~0000030

Revision 777 should get rid of the issue.

Saga Musix

Saga Musix

2011-01-05 20:13

administrator   ~0000033

Still waiting for confirmation... Check out http://sagagames.de/stuff/mptrack.exe

Saga Musix

Saga Musix

2011-03-09 00:02

administrator   ~0000090

Reminder sent to: harbinger

Bump. :)

harbinger

harbinger

2011-03-29 20:35

reporter   ~0000118

(1.19.00.30)

I finally got the chance (and remembered) to test this...

Test on Note Properties input undo:
I tested the Undo function for entering notes via the Note Properties dialog in an MPTM track. I first double-clicked an event field and selected an instrument at random. Then i went to another row and did the same thing but selected a note FX command. Then again, but for a channel FX command. And lastly, a note with an instrument call. I ended up with:
... 01 .. ...
... .. e00 ...
... .. .. #4A
F-6 06 .. ...

When i pressed the Undo shortcut, only the first entry was erased. Subsequent undo's did not work. After further entries by the dialog, Undo would not work. I also checked the menu in case there was something wrong with the shortcut, but the Edit menu's Undo item was disabled (grayed out).

So after testing, the Undo only works with the first entry from Note Properties, but none after. I would say it's still not working.

Saga Musix

Saga Musix

2011-03-29 20:39

administrator   ~0000120

Last edited: 2011-03-29 20:43

View 2 revisions

Ah, I see what is happening there. I actually wanted to create just one undo point, but apparently that backfired, because the variable for that is apparently not reset properly. Will be fixed in 1.19 Final...

Saga Musix

Saga Musix

2011-04-01 17:01

administrator   ~0000122

Please check if OpenMPT 1.19 final works as desired.

harbinger

harbinger

2011-04-04 20:18

reporter   ~0000131

Yes, works as expected. You may consider this bug fixed.

Good job, and thanks, Jojo! (in case no one ever mentions it;)

Issue History

Date Modified Username Field Change
2010-12-23 17:39 harbinger New Issue
2010-12-23 21:36 Saga Musix Assigned To => Saga Musix
2010-12-23 21:36 Saga Musix Status new => assigned
2010-12-23 21:37 Saga Musix Product Version => OpenMPT 1.18.03.00 (upgrade first)
2010-12-23 21:37 Saga Musix Target Version => OpenMPT 1.19.01.00 (upgrade first)
2010-12-23 23:28 Saga Musix Note Added: 0000030
2010-12-23 23:28 Saga Musix Status assigned => feedback
2010-12-23 23:28 Saga Musix Fixed in Version => OpenMPT 1.19.00.* (old testing)
2011-01-05 20:13 Saga Musix Note Added: 0000033
2011-03-09 00:02 Saga Musix Note Added: 0000090
2011-03-26 16:34 Saga Musix Status feedback => resolved
2011-03-26 16:34 Saga Musix Resolution open => fixed
2011-03-29 20:35 harbinger Note Added: 0000118
2011-03-29 20:35 harbinger Status resolved => feedback
2011-03-29 20:35 harbinger Resolution fixed => reopened
2011-03-29 20:39 Saga Musix Note Added: 0000120
2011-03-29 20:43 Saga Musix Note Edited: 0000120 View Revisions
2011-04-01 17:01 Saga Musix Note Added: 0000122
2011-04-01 17:01 Saga Musix Target Version OpenMPT 1.19.01.00 (upgrade first) => OpenMPT 1.19.00.* (old testing)
2011-04-01 17:08 Saga Musix Target Version OpenMPT 1.19.00.* (old testing) => OpenMPT 1.19.01.00 (upgrade first)
2011-04-04 20:18 harbinger Note Added: 0000131
2011-04-04 20:18 harbinger Status feedback => assigned
2011-04-04 22:11 Saga Musix Status assigned => resolved
2011-04-04 22:11 Saga Musix Resolution reopened => fixed