View Issue Details

IDProjectCategoryView StatusLast Update
0000045OpenMPT[All Projects] Feature Requestpublic2011-01-11 18:04
Reporterharbinger Assigned ToSaga Musix  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionOpenMPT 1.19.01.00 (upgrade first)Fixed in VersionOpenMPT 1.19.01.00 (upgrade first) 
Summary0000045: Row Selection
Description

Clicking on the row numbers (on the left side of the Pattern Editor) would select the entire row (the cursor would stay in its current spot). This would emulate a feature of many spreadsheet programs, making it easy to select entire rows without having to move the cursor to the last channel.

Additional Information

Source topic: http://forum.openmpt.org/index.php?topic=4130.0

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2010-12-02 22:53

administrator   ~0000014

Revision 767 introduces Excel/Calc-style row selection.

Saga Musix

Saga Musix

2010-12-03 22:39

administrator   ~0000018

Please try http://sagagames.de/stuff/mptrack.exe and confirm that the feature has been implemented as expected.

harbinger

harbinger

2010-12-17 15:08

reporter   ~0000024

Row Select works great under normal use. The selection is kept separate from the input cursor (which stays where you left it), so this works like regular click-and-drag.

I did notice two quirks that are of extremely minor importance. (I had to go out of my my way to find these.)

  1. Drag-clicking a row, where your mouse is first clicked in the row header but ends inside a column will still select the rows that were dragged. This is a nice little featurette since you don't have to keep your mouse in the row headers to select the rows.

  2. Shift-clicking has an odd side-effect, if you do it like this: use Row Select as normal, but after beginning your drag, press Shift. The selection will now start at the channel where the INPUT cursor is, and select all rows between that and your mouse, but only the columns AFTER the cursor. This might be used as a way to filter your selection by selecting all columns in the Row Select after the input cursor's location.

Neither of these i'm sure were intentional, and again, they're not important enough to waste time on if you don't like these behaviors.

Definitely a keeper. Good work as always, Jojo! :)

Saga Musix

Saga Musix

2010-12-17 16:40

administrator   ~0000025

The first is fully intentional, however the second one is not. I guess I will try to remove that "feature", since it is not straight-forward at all.

Saga Musix

Saga Musix

2010-12-18 19:06

administrator   ~0000028

Revision 773 fixes the second issue. (Same download link as always)

Saga Musix

Saga Musix

2011-01-05 20:13

administrator   ~0000032

Still waiting for confirmation...

harbinger

harbinger

2011-01-10 20:55

reporter   ~0000034

Tested Row Select and it works perfectly. Will write it up for OHM.

That's a wrap, people!

Issue History

Date Modified Username Field Change
2010-11-29 21:10 harbinger New Issue
2010-11-29 21:49 Saga Musix Priority low => normal
2010-11-29 21:49 Saga Musix Severity minor => feature
2010-11-29 21:49 Saga Musix Summary REQUEST: Row Selection => Row Selection
2010-11-29 22:23 Saga Musix Assigned To => Saga Musix
2010-11-29 22:23 Saga Musix Status new => assigned
2010-11-29 22:23 Saga Musix Target Version => OpenMPT 1.19.01.00 (upgrade first)
2010-11-29 22:44 Saga Musix Additional Information Updated View Revisions
2010-11-29 22:45 Saga Musix OS XP =>
2010-11-29 22:45 Saga Musix Platform Windows =>
2010-12-02 22:53 Saga Musix Note Added: 0000014
2010-12-03 22:39 Saga Musix Note Added: 0000018
2010-12-03 22:39 Saga Musix Status assigned => feedback
2010-12-17 15:08 harbinger Note Added: 0000024
2010-12-17 15:08 harbinger Status feedback => assigned
2010-12-17 16:40 Saga Musix Note Added: 0000025
2010-12-18 19:06 Saga Musix Note Added: 0000028
2010-12-18 19:06 Saga Musix Status assigned => feedback
2011-01-05 20:13 Saga Musix Note Added: 0000032
2011-01-10 20:55 harbinger Note Added: 0000034
2011-01-10 20:55 harbinger Status feedback => assigned
2011-01-11 18:04 Saga Musix Resolution open => fixed
2011-01-11 18:04 Saga Musix Fixed in Version => OpenMPT 1.19.00.* (old testing)
2011-01-11 18:04 Saga Musix Status assigned => resolved