View Issue Details

IDProjectCategoryView StatusLast Update
0000427OpenMPTGeneralpublic2013-08-02 12:24
ReporterJojotjuh Assigned ToSaga Musix  
Status resolvedResolutionnot fixable 
Platformx64OSWindowsOS Version8
Product VersionOpenMPT (upgrade first) 
Summary0000427: Crash upon startup

I have a laptop running Windows 8 x64 on an intel core i7 2670qm with 16GiB of RAM.

On a previous installation of windows 8 x64 on the exact same machine, I could open openmpt just fine. However, a clean install of windows 8 on a new SSD (Samsung 840 Pro 256) yields that I can no longer start openMPT.

It comes up immediately with a message saying "Unhandled exception 0xC0000005 at address 63EE39F4 occoured" (There's a typo, there, too.)

I've tested my RAM to make sure it wasn't that but it passed 4 passes in Memtest 4.20 so I'm sure that's not it.

Steps To Reproduce

start OpenMPT

Additional Information

I have attached the crash dump file.

TagsNo tags attached.
Attached Files (8,763 bytes)
Has the bug occurred in previous versions?It hasn't before, but older versions that also used to work before, crash now as well. Same error message.
Tested code revision (in case you know it)


Saga Musix

Saga Musix

2013-08-01 13:02

administrator   ~0001322

Last edited: 2013-08-01 13:06

There's a crash happening in the ASIO driver for some kind of USB sound card when trying to retrieve the sound card's sampling rate. Is your USB soundcard attached to the system? If it isn't, try doing so.
Btw, where's the typo supposed to be? I don't see any typos. ;)



2013-08-01 13:10

reporter   ~0001323

Last edited: 2013-08-01 13:12

Weird. The only USB things I have are a Mouse and Blue Snowball Microphone. My internal soundcard is a Realtek ALC663 chip.

Windows only lists 3 devices under Audio: Blue Snowball, NVIDIA Virtual Audio Device, and Realtek HD Audio.

I don't remember ever installing anything ASIO related.

Edit: The typo is "Occoured", supposed to be spelled "occurred" :)

Saga Musix

Saga Musix

2013-08-01 13:17

administrator   ~0001324

That's weird. But apparently you do have an ASIO sound driver installed, because otherwise OpenMPT wouldn't try to query its capabilities. The driver in question is called CMUSBDACASIO.DLL (C-Media USB DAC ASIO?), which is why I assumed it might come from an external sound card. Strangely enough, searching for that file name on Google does not yield any sensible results. Do you have some kind of C-Media audio device?
The fact that such a device is not supposed to be available would explain the crash, though.

So this looks like some kind of broken driver to me and I don't think I can do anything about it. However, you can get OpenMPT to run by placing the following lines in your OpenMPT configuration file, located at %APPDATA%\OpenMPT\mptrack.ini:

[Sound Settings]

OpenMPT should be able to start again with this configuration and use a WASAPI driver instead of ASIO. You may then go to the options dialog and see how the ASIO driver is called there, to get some more clues.



2013-08-01 13:38

reporter   ~0001325

That sounds logical indeed. I don't have any C-Media devices, but it does indeed list in the Sound Card / Sound Devices list in OpenMPT and it does seem to crash again when selecting that device.

This seems to solve my problem; I'll look into this mystery device driver because it wasn't there in my previous win8 installation and this is a clean one I am running now.

I'll report back if I find out where it came from, but I thank you for your help :)

Saga Musix

Saga Musix

2013-08-01 13:42

administrator   ~0001326

Glad to hear that it works now. But it's not really satisfactory that OpenMPT may crash on a clean install, so here's something to try:
Will OpenMPT still crash when you try selecting that ASIO driver in this version?



2013-08-01 13:44

reporter   ~0001327

I tried this version, and it did indeed still crash, although the error address was different: 70b339b1.

Saga Musix

Saga Musix

2013-08-01 13:46

administrator   ~0001328

Alright, I probably can't catch that crash then, too bad. It was worth a try. :) I'll close this issue, but if you have any new useful findings, feel free to add another comment.

Saga Musix

Saga Musix

2013-08-02 12:24

administrator   ~0001329

Addendum from private message: The C-Media drivers seem to come from a Blue Snowball driver update.

Issue History

Date Modified Username Field Change
2013-08-01 12:49 Jojotjuh New Issue
2013-08-01 12:49 Jojotjuh File Added:
2013-08-01 13:02 Saga Musix Note Added: 0001322
2013-08-01 13:06 Saga Musix Note Edited: 0001322
2013-08-01 13:10 Jojotjuh Note Added: 0001323
2013-08-01 13:12 Jojotjuh Note Edited: 0001323
2013-08-01 13:12 Jojotjuh Description Updated
2013-08-01 13:17 Saga Musix Note Added: 0001324
2013-08-01 13:38 Jojotjuh Note Added: 0001325
2013-08-01 13:42 Saga Musix Note Added: 0001326
2013-08-01 13:44 Jojotjuh Note Added: 0001327
2013-08-01 13:46 Saga Musix Note Added: 0001328
2013-08-01 13:46 Saga Musix Status new => resolved
2013-08-01 13:46 Saga Musix Resolution open => not fixable
2013-08-02 12:24 Saga Musix Note Added: 0001329
2013-08-02 12:24 Saga Musix Assigned To => Saga Musix