View Issue Details

IDProjectCategoryView StatusLast Update
0000037OpenMPT[All Projects] Generalpublic2012-03-08 23:06
ReporterSaga MusixAssigned To 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionnot fixable 
Product VersionOpenMPT 1.19.00.* (old testing) 
Target VersionFixed in Version 
Summary0000037: OpenMPT process remains on exit
Description

Sometimes, the OpenMPT process (mptrack.exe) remains in the task list even after closing the program. This seems to be reproducable when using certain (or a combination of) VST plugins.

Steps To Reproduce

Try the attached file (courtesy of jmkz)

TagsNo tags attached.
Has the bug occurred in previous versions?Not tested.
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2010-11-08 21:19

administrator  

beat-test5.7z (178,215 bytes)
Saga Musix

Saga Musix

2010-11-08 22:06

administrator   ~0000006

Additional discovery: It is probably already enough to just close the track (not OpenMPT) while it's playing, it can also freeze OpenMPT then. The freeze seems to happen in DWORD WINAPI CMainFrame::AudioThread(LPVOID).

LPChip

LPChip

2010-11-09 10:57

manager   ~0000007

Best way to test this, is by doing the following:

Create a .cmd or .bat file, and call mptrack.exe from within this file.

During the OpenMPT session, the .bat or .cmd file will be kept open, and it will close after the mptrack.exe process stops. If this fails, and you close OpenMPT, the batchfile will also remain open. This saves you from going into the taskmanager to verify that the process is still open. Of course, you will need to still go there in case you want to close the process.

Saga Musix

Saga Musix

2012-03-08 23:06

administrator   ~0000649

As discovered before, this behaviour is caused by the V2 plugin and is reproducable in any other host as well, so it's not fixable.

Issue History

Date Modified Username Field Change
2010-11-08 21:19 Saga Musix New Issue
2010-11-08 21:19 Saga Musix File Added: beat-test5.7z
2010-11-08 21:32 Saga Musix Status new => confirmed
2010-11-08 22:06 Saga Musix Note Added: 0000006
2010-11-09 10:57 LPChip Note Added: 0000007
2012-03-08 23:06 Saga Musix Note Added: 0000649
2012-03-08 23:06 Saga Musix Status confirmed => closed
2012-03-08 23:06 Saga Musix Resolution open => not fixable