View Issue Details

IDProjectCategoryView StatusLast Update
0000034OpenMPT[All Projects] Feature Requestpublic2012-12-08 19:41
ReporterrakibAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionOpenMPT 1.21.01.00 (upgrade first)Fixed in VersionOpenMPT 1.21.01.00 (upgrade first) 
Summary0000034: Ability to use transpose+1 over the entire pattern
Description

More info here:
http://forum.openmpt.org/index.php?topic=3702.0

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2012-11-16 22:53

administrator   ~0000934

I've added two generic shortcuts: Data Entry +1 and Data Entry -1. They can be used to increase or decrease anything that seemed to make sense to me (notes, instruments and effect parameters - not effect letters). Maybe you want to try this out... http://sagagames.de/stuff/mptrack.exe

rakib

rakib

2012-11-17 10:44

reporter   ~0000935

This is just pure awesomeness, this will improve workflow a lot!

Saga Musix

Saga Musix

2012-11-17 13:22

administrator   ~0000936

If you have any comments on how it could be improved, please let me know, so I can fix it before the next release. I still don't think that it would make sense to jump from B-9 to e.g. ^^ as in your original request, but maybe it should at least be possible to cycle between ^^, ==, ~~ and PC Notes using this feature.

rakib

rakib

2012-11-17 14:00

reporter   ~0000939

1.
I understand why you may not want ^^, ==, ~~ included but sometimes its faster to just traverse to a ~~ instead of finding that shortcut that leads to ~~. I usually dont remember all of them and them I have to click with the mouse to get to note properties and find ~~ which takes some times.

  1. Second improvement is to able to go from B9 to C0 and backwards.
Saga Musix

Saga Musix

2012-11-17 20:04

administrator   ~0000958

Regarding 1, I think remembering at least one easily accesible shortcut shouldn't be to hard, right? That's why I think cycling through special notes could be included, but it should stay separate from normal notes.

Regarding 2, I thought about adding a "cycle" mode, but I'm not sure how useful this actually would be. Even if you are that lazy that you want to hit just one key, I think it would be faster to hit the "0" key if you quickly want to get to the lowest octave.

rakib

rakib

2012-11-17 20:28

reporter   ~0000959

I am very content with what you have made so far, so I am very happy.

Saga Musix

Saga Musix

2012-12-01 18:33

administrator   ~0000985

I've modified the behaviour so that cycling between the various "special" notes is also possible now.

rakib

rakib

2012-12-08 19:19

reporter   ~0000993

Works as intended.

Saga Musix

Saga Musix

2012-12-08 19:41

administrator   ~0000994

Alright, I'll mark this as resolved then. If there are any more ideas on how to improve this feature, open a new issue for them.

Issue History

Date Modified Username Field Change
2010-11-08 14:19 rakib New Issue
2012-11-16 22:53 Saga Musix Note Added: 0000934
2012-11-16 22:53 Saga Musix Assigned To => Saga Musix
2012-11-16 22:53 Saga Musix Status new => feedback
2012-11-17 10:44 rakib Note Added: 0000935
2012-11-17 10:44 rakib Status feedback => assigned
2012-11-17 13:22 Saga Musix Note Added: 0000936
2012-11-17 13:22 Saga Musix Status assigned => feedback
2012-11-17 14:00 rakib Note Added: 0000939
2012-11-17 14:00 rakib Status feedback => assigned
2012-11-17 20:04 Saga Musix Note Added: 0000958
2012-11-17 20:28 rakib Note Added: 0000959
2012-12-01 18:33 Saga Musix Note Added: 0000985
2012-12-01 18:33 Saga Musix Status assigned => feedback
2012-12-08 19:19 rakib Note Added: 0000993
2012-12-08 19:19 rakib Status feedback => assigned
2012-12-08 19:41 Saga Musix Note Added: 0000994
2012-12-08 19:41 Saga Musix Reproducibility have not tried => N/A
2012-12-08 19:41 Saga Musix Status assigned => resolved
2012-12-08 19:41 Saga Musix Resolution open => fixed
2012-12-08 19:41 Saga Musix Fixed in Version => OpenMPT 1.21.01.00 (upgrade first)
2012-12-08 19:41 Saga Musix Target Version => OpenMPT 1.21.01.00 (upgrade first)