View Issue Details

IDProjectCategoryView StatusLast Update
0000315OpenMPT[All Projects] Playback Compatibilitypublic2012-12-01 14:24
ReporterNero1024 Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionwon't fix 
Platformx86OSWindowsOS VersionVista
Product VersionOpenMPT 1.20.04.00 (upgrade first) 
Target VersionFixed in Version 
Summary0000315: .XM files saved through this version can't be played in Winamp
Description

.XM files saved through this version of ModPlug can't be played in Winamp (says "Corrupt file or unsupported module type").

Steps To Reproduce

Save any file as .xm, play in Winamp.

Additional Information

The Winamp version is latest (v5.63), though the .xm files saved in this version of ModPlug can still be played in XMPlay.

Weird enough saving .xm files w/ an older version (1.17.02.54) doesn't give this issue.

Attached should be a 7Zip file with a .xm file that I scrapped together.

TagsNo tags attached.
Has the bug occurred in previous versions?Yes 1.20.02.00
Tested code revision (in case you know it)

Activities

Nero1024

Nero1024

2012-11-24 04:52

reporter  

MelRipp1-3.7z (501,736 bytes)
Saga Musix

Saga Musix

2012-11-24 13:08

administrator   ~0000974

Last edited: 2012-11-24 13:10

View 2 revisions

It's an issue with WinAmp, not OpenMPT. WinAmp uses a really crappy module player (MikMod) which plays many modules wrong and doesn't even load some correctly formatted modules. You will not be able to play XMs compressed with BoobieSqueezer in WinAmp for the same reason. Since the code change in OpenMPT is valid and does not generate broken XMs by definition, I am not going to revert it. I suggest you to replace the default WinAmp plugin with a better one (e.g. http://www.winamp.com/plugin/bass-module-player/132367), or switch to XMPlay, which has far better module support than WinAmp has.
See also: http://wiki.openmpt.org/Manual:_Frequently_Asked_Questions#My_files_do_not_open_in_MikMod_.2F_FMOD_.2F_name_your_player_here

Saga Musix

Saga Musix

2012-12-01 14:24

administrator   ~0000982

FYI I have posted about this issue on the Winamp bug report forums, I have no idea if they are going to do something about it, though: http://forums.winamp.com/showthread.php?t=352991

Issue History

Date Modified Username Field Change
2012-11-24 04:52 Nero1024 New Issue
2012-11-24 04:52 Nero1024 File Added: MelRipp1-3.7z
2012-11-24 04:57 Nero1024 Has the bug occurred in previous versions? 1.20.02.00 => Yes 1.20.02.00
2012-11-24 13:08 Saga Musix Note Added: 0000974
2012-11-24 13:08 Saga Musix Status new => closed
2012-11-24 13:08 Saga Musix Resolution open => won't fix
2012-11-24 13:10 Saga Musix Note Edited: 0000974 View Revisions
2012-12-01 14:24 Saga Musix Note Added: 0000982