View Issue Details

IDProjectCategoryView StatusLast Update
0000313OpenMPT[All Projects] Feature Requestpublic2012-11-24 16:15
Reportermoltres_riderAssigned ToSaga Musix 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformx86OSWindowsOS Version7
Product VersionOpenMPT 1.20.04.00 (upgrade first) 
Target VersionOpenMPT 1.21.01.00 (upgrade first)Fixed in VersionOpenMPT 1.21.01.00 (upgrade first) 
Summary0000313: DLS Level 2 Soundbanks remain silent
Description

I think Modplug should have support for using DLS soundbanks loaded for instruments and/or samples in modules

Additional Information

about DLS soundbanks

http://en.wikipedia.org/wiki/DLS_format

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2012-11-17 17:33

administrator   ~0000955

You can add DLS banks to the tree view by right-clicking and choosing "Add Sound Bank". What's the novelty of this feature request?

Saga Musix

Saga Musix

2012-11-20 23:34

administrator   ~0000967

Uhm, so what is the status on this? Does adding sound banks via the treeview do what you do or do you mean something completely different?

moltres_rider

moltres_rider

2012-11-21 03:25

reporter   ~0000968

Last edited: 2012-11-21 03:25

View 2 revisions

no it doesn't work!!! all dls banks are silent when loaded into instruments in ModPlug!!! I dragged a sound in the bank to the 'instruments' tab and a silent instrument was created!!! no sound for sample or instrument!!! the dls files work in other programs that accept them!!!

Saga Musix

Saga Musix

2012-11-21 13:09

administrator   ~0000969

Then FFS let all this guesswork end and tell me what DLS bank you want to load into OpenMPT. I have only worked with very few DLS banks in the past, and they all loaded perfectly. My best guess right now would be that they are DLS2 banks, which OpenMPT might not support, but again, please be more specific and don't make me have to make random guesses and assumptions.

moltres_rider

moltres_rider

2012-11-21 19:10

reporter   ~0000970

I used a program that rips Nintendo DS game music instruments into DLS files, others I've converted sf2 into dls, and a few packed dls files from Sony ACID... according to Awave Studio they are all level 1 dls!!! all of which are silent!!!

Saga Musix

Saga Musix

2012-11-21 19:11

administrator   ~0000971

Do you think this information is helpful to me? I was asking for DLS banks to try, not where you get them from.

moltres_rider

moltres_rider

2012-11-21 20:08

reporter   ~0000972

here is three... http://www.mediafire.com/?foqp2cjtq9wtua3

Saga Musix

Saga Musix

2012-11-21 22:44

administrator   ~0000973

The files in question are DLS Level 2, which is not supported by OpenMPT. I have added very rudimentary support for DLS Level 2 regions, which will treat them just like DLS Level 1 regions, so sounds are at least loaded, but I won't give any guarantees that they sounded as intended. And I won't go further than that with supporting DLS Level 2. http://sagagames.de/stuff/mptrack.exe should make the samples in these sound banks load.

Saga Musix

Saga Musix

2012-11-24 14:13

administrator   ~0000975

So, does this solve the problem or not?

moltres_rider

moltres_rider

2012-11-24 16:13

reporter   ~0000976

oh, sorry... as I said in the forums, I traveled to Chicago... seems to work...

Issue History

Date Modified Username Field Change
2012-11-17 17:08 moltres_rider New Issue
2012-11-17 17:33 Saga Musix Note Added: 0000955
2012-11-20 23:34 Saga Musix Note Added: 0000967
2012-11-21 03:25 moltres_rider Note Added: 0000968
2012-11-21 03:25 moltres_rider Note Edited: 0000968 View Revisions
2012-11-21 13:09 Saga Musix Note Added: 0000969
2012-11-21 19:10 moltres_rider Note Added: 0000970
2012-11-21 19:11 Saga Musix Note Added: 0000971
2012-11-21 20:08 moltres_rider Note Added: 0000972
2012-11-21 22:44 Saga Musix Note Added: 0000973
2012-11-21 22:44 Saga Musix Assigned To => Saga Musix
2012-11-21 22:44 Saga Musix Status new => feedback
2012-11-21 22:45 Saga Musix Product Version => OpenMPT 1.20.04.* (old testing)
2012-11-21 22:45 Saga Musix Summary support for DLS Soundbanks as samples/instruments => DLS Level 2 Soundbanks remain silent
2012-11-24 14:13 Saga Musix Note Added: 0000975
2012-11-24 16:13 moltres_rider Note Added: 0000976
2012-11-24 16:13 moltres_rider Status feedback => assigned
2012-11-24 16:15 Saga Musix Status assigned => resolved
2012-11-24 16:15 Saga Musix Resolution open => fixed
2012-11-24 16:15 Saga Musix Product Version OpenMPT 1.20.04.* (old testing) => OpenMPT 1.20.04.00 (upgrade first)
2012-11-24 16:15 Saga Musix Fixed in Version => OpenMPT 1.21.01.00 (upgrade first)
2012-11-24 16:15 Saga Musix Target Version => OpenMPT 1.21.01.00 (upgrade first)