View Issue Details

IDProjectCategoryView StatusLast Update
0000028OpenMPTUser Interfacepublic2010-11-08 14:08
ReporterReally Weird Person Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.19.00.* (old testing) 
Target VersionOpenMPT 1.19.01.00 (upgrade first)Fixed in VersionOpenMPT 1.19.01.00 (upgrade first) 
Summary0000028: Position Aware Timer not updated when using Goto
Description

It would seem the position aware timer (which is nice, by the way, epecially since it is integrated right into version 1.19.00.10) does not function as expected. When using Control-left arrow or Control-right arrow or clicking a pattern number, the time changes; however, it does not when using the Go to… dialog.

Steps To Reproduce
  1. Create or open a module with two or more patterns in it.
  2. Use either Control-left arrow or Control-right arrow and note the time change.
  3. Use the Go to… dialog and go to a different pattern. You should observe that the time does not change.
Additional Information

It would seem that this is fixed indeed. It would seem that it still does not do it real time, meaning, as the patterns are navigated by row (to include navigation to the next or previous pattern) the playback time does not change. Perhaps this was not done because it was not seen as nearly as practical.

TagsNo tags attached.
Has the bug occurred in previous versions?Yes, 1.19.00.00
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2010-11-07 16:38

administrator   ~0000004

Please confirm that OpenMPT 1.19.0.12 fixes this issue: http://sagagames.de/stuff/mptrack.exe

Saga Musix

Saga Musix

2010-11-08 14:07

administrator   ~0000005

Re your additional information (please use comments for additions like that in the future): No, it is currently impractical to change the display while navigating though the patterns.

Issue History

Date Modified Username Field Change
2010-11-06 22:57 Really Weird Person New Issue
2010-11-07 16:28 Saga Musix Assigned To => Saga Musix
2010-11-07 16:28 Saga Musix Status new => confirmed
2010-11-07 16:28 Saga Musix Target Version => OpenMPT 1.19.01.00 (upgrade first)
2010-11-07 16:38 Saga Musix Note Added: 0000004
2010-11-07 16:38 Saga Musix Status confirmed => feedback
2010-11-07 16:44 Saga Musix Summary Position Aware Timer Not Functioning As Expected => Position Aware Timer not updated when using Goto
2010-11-07 19:33 Really Weird Person Additional Information Updated View Revisions
2010-11-08 14:07 Saga Musix Note Added: 0000005
2010-11-08 14:08 Saga Musix Status feedback => resolved
2010-11-08 14:08 Saga Musix Resolution open => fixed
2010-11-08 14:08 Saga Musix Fixed in Version => OpenMPT 1.19.00.* (old testing)