View Issue Details

IDProjectCategoryView StatusLast Update
0000020OpenMPT[All Projects] User Interfacepublic2010-11-17 22:36
ReporterSaga MusixAssigned ToSaga Musix 
PrioritynoneSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.18.03.00 (upgrade first) 
Target VersionOpenMPT 1.19.01.00 (upgrade first)Fixed in VersionOpenMPT 1.19.01.00 (upgrade first) 
Summary0000020: "Config to load on startup" in Keyboard Manager is buggy/useless
Description

The "Config to load on startup" option in the keyboard manager is pretty useless in its current state. When you load a new key config, it will automatically overwrite your currently active config, and even worse, those changes will be saved to your previously active config file, at least if you answer the "Load this file on startup" question with "no".

Steps To Reproduce

1) Backup your own key config file.
2) Load a new key config file, but don't select "load on startup".
3) Apply changes. Note that the new config file is now active.
4) Close OpenMPT and open it again
5) You should notice that the old config is still active, and that your own config file which you previously used now contains the same key mappins as the one your loaded in step 2).

Additional Information

The problem is that the config is not written to %APPDATA%\OpenMPT\Keybindings.mkb but to the config file selected by the user. This should be only be done when using the "Save" buton.

TagsNo tags attached.
Has the bug occurred in previous versions?Yes, all of them.
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2010-11-17 22:36

administrator   ~0000009

Behaviour change in rev. 762: Keymaps are now always written to Keybindings.mkb.

Issue History

Date Modified Username Field Change
2010-11-06 12:13 Saga Musix New Issue
2010-11-06 12:13 Saga Musix Priority normal => none
2010-11-06 12:13 Saga Musix Status new => confirmed
2010-11-13 16:16 Saga Musix Assigned To => Saga Musix
2010-11-13 16:16 Saga Musix Status confirmed => assigned
2010-11-13 16:16 Saga Musix Target Version => OpenMPT 1.19.00.* (old testing)
2010-11-13 16:16 Saga Musix Target Version OpenMPT 1.19.00.* (old testing) => OpenMPT 1.19.01.00 (upgrade first)
2010-11-17 22:36 Saga Musix Note Added: 0000009
2010-11-17 22:36 Saga Musix Status assigned => resolved
2010-11-17 22:36 Saga Musix Fixed in Version => OpenMPT 1.19.00.* (old testing)
2010-11-17 22:36 Saga Musix Resolution open => fixed