View Issue Details

IDProjectCategoryView StatusLast Update
0000194OpenMPT[All Projects] Feature Requestpublic2015-04-18 16:31
ReporterharbingerAssigned ToSaga Musix 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Platformx86OSWindowsOS VersionXP
Product Version 
Target VersionOpenMPT 1.22.01.00 (upgrade first)Fixed in VersionOpenMPT 1.22.01.00 (upgrade first) 
Summary0000194: Rename Pattern shortcut
Description

I often keep up with Pattern functions by naming them, such as "Verse 1 Line 1" or "Abm7 -> Gm6". However, duplicating a whole series (a god-sent feature) means i hafta go back and rename each pattern. This can only be done by clicking on the pattern index in the Order List, clicking in the Pattern name field to focus the input, type the name, then start over. Moving between mouse and keyboard more than once or twice begins to cause my inspiration to fade.

What we need is either:

  1. "Previous" and "Next" buttons in the Pattern Properties dialog, plus the ability to name Patterns there, OR
  2. A global keyboard shortcut to open a Rename dialog (or the Pattern Properties dialog with the option to name the pattern), so all i hafta do is make sure either the Order List, Pattern Editor, or a pattern in the Folder Tree has focus, press the shortcut, type the name, press Enter, then press the Prev/Next Pattern shortcut, and repeat, OR
  3. A new Pattern Manager dialog, which allows you to create the song structure from one dialog, as envisioned in this FR: http://forum.openmpt.org/index.php?topic=4100.0.
TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

harbinger

harbinger

2011-10-05 14:55

reporter  

MyNewPatternAttributes.jpg (107,229 bytes)
MyNewPatternAttributes.jpg (107,229 bytes)
Saga Musix

Saga Musix

2015-03-09 16:43

administrator   ~0001972

Notice that you can rename patterns in the tree view by slowly double-clicking their labels or hitting Ctrl+Enter. Would that suit your use case?

Saga Musix

Saga Musix

2015-03-20 15:51

administrator   ~0002018

Any input on my suggestion?

harbinger

harbinger

2015-03-20 19:31

reporter   ~0002019

Have yet to try it.

Can you post a quick link to the nightly?

Saga Musix

Saga Musix

2015-03-20 19:37

administrator   ~0002020

That feature has been part of OpenMPT since at least version 1.23.

Issue History

Date Modified Username Field Change
2011-10-05 14:55 harbinger New Issue
2011-10-05 14:55 harbinger File Added: MyNewPatternAttributes.jpg
2015-03-09 16:43 Saga Musix Note Added: 0001972
2015-03-09 20:29 Saga Musix Assigned To => Saga Musix
2015-03-09 20:29 Saga Musix Status new => feedback
2015-03-20 15:51 Saga Musix Note Added: 0002018
2015-03-20 19:31 harbinger Note Added: 0002019
2015-03-20 19:31 harbinger Status feedback => assigned
2015-03-20 19:37 Saga Musix Note Added: 0002020
2015-03-20 19:38 Saga Musix Status assigned => feedback
2015-04-18 16:31 Saga Musix Status feedback => resolved
2015-04-18 16:31 Saga Musix Resolution open => fixed
2015-04-18 16:31 Saga Musix Fixed in Version => OpenMPT 1.22.01.00 (upgrade first)
2015-04-18 16:31 Saga Musix Target Version => OpenMPT 1.22.01.00 (upgrade first)