View Issue Details

IDProjectCategoryView StatusLast Update
0000018OpenMPT[All Projects] Plugins / VSTpublic2014-02-13 08:45
ReporterSaga MusixAssigned ToSaga Musix 
PrioritynormalSeverityminorReproducibilityrandom
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.18.03.00 (upgrade first) 
Target VersionOpenMPT 1.23.01.00 (upgrade first)Fixed in VersionOpenMPT 1.23.01.00 (upgrade first) 
Summary0000018: Buggy plugin cache: "Forgets" about plugins and keeps corrupted ones.
Description

Some VSTs (f.e. the Juno6 VSTi) are not supported by OpenMPT. You get an error message when adding them and afterwards, they are of course not shown in the VST manager. However, they seem to be kept in the VST list in mptrack.ini, so everytime you start MPT, you'll get a warning (until you remove it from the mptrack.ini...)

A similar problem is that plugins seem to randomly vanish from the mptrack.ini plugin list, i.e. they are still in the file (f.e. Plugin55=foo.dll), but NumPlugins is too low (f.e. NumPlugin = 50).

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

related to 0000155 closed OpenMPT replaces/duplicates entries of VST's in mptrack.ini 

Activities

Saga Musix

Saga Musix

2013-11-17 22:14

administrator   ~0001376

I have re-implemented the plugin manager using std::vector instead of hand-written pointer magic after I noticed some anomalies. It's highly possible that the latest revisions finally fix this problem, but since it happens randomly, I can only make assumptions.

Saga Musix

Saga Musix

2013-12-01 16:32

administrator   ~0001395

I'll close this report and re-open it if the problem happens to re-appear. So far, it seems to be fixed.

Issue History

Date Modified Username Field Change
2010-11-06 12:02 Saga Musix New Issue
2010-11-06 12:02 Saga Musix Status new => confirmed
2011-07-23 12:13 Saga Musix Relationship added related to 0000155
2013-11-17 22:13 Saga Musix Assigned To => Saga Musix
2013-11-17 22:13 Saga Musix Status confirmed => assigned
2013-11-17 22:14 Saga Musix Note Added: 0001376
2013-12-01 16:32 Saga Musix Note Added: 0001395
2013-12-01 16:32 Saga Musix Status assigned => resolved
2013-12-01 16:32 Saga Musix Resolution open => fixed
2013-12-01 16:32 Saga Musix Fixed in Version => OpenMPT 1.23.01.00 (upgrade first)
2013-12-01 16:32 Saga Musix Target Version => OpenMPT 1.23.01.00 (upgrade first)
2016-11-20 17:48 Saga Musix Category VST => Plugins (VST)
2016-11-20 17:48 Saga Musix Category Plugins (VST) => Plugins / VST