View Issue Details

IDProjectCategoryView StatusLast Update
0001794OpenMPTUser Interfacepublic2024-06-26 16:16
ReporterAmaroq_Dricaldari Assigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionduplicate 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.31.08.00 / libopenmpt 0.7.8 (current stable) 
Summary0001794: Add a dark mode for the whole interface (independent of system theme)
Description

Tried to convince a colleague to give OpenMPT a shot, but they described the UI around the pattern editor (which you can't change the color of, unlike the pattern editor) as a trip to the dentist's office crossed with Microsoft Excel.

Meanwhile, I'm using Windows in dark mode, and... the whole UI is still a glaring white.
Giving the whole tracker a dark mode, and enabling it to be configured separately from the system theme, would go a long way toward improving usability for everyone.

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Relationships

duplicate of 0001586 new Add dark mode to MPT 

Activities

Saga Musix

Saga Musix

2024-06-26 16:16

administrator   ~0005981

Please do at least a very basic search before posting a feature request. Just searching for "dark mode" would have brought up several duplicate issues.

Issue History

Date Modified Username Field Change
2024-06-26 15:44 Amaroq_Dricaldari New Issue
2024-06-26 16:16 Saga Musix Note Added: 0005981
2024-06-26 16:16 Saga Musix Status new => closed
2024-06-26 16:16 Saga Musix Resolution open => duplicate
2024-06-26 16:16 Saga Musix Relationship added duplicate of 0001586