View Issue Details

IDProjectCategoryView StatusLast Update
0001739OpenMPTAccessibilitypublic2024-01-11 11:53
ReporterStardown Assigned ToSaga Musix  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version11
Product VersionOpenMPT 1.31.04.00 / libopenmpt 0.7.3 (current stable) 
Target VersionOpenMPT 1.31.05.00 / libopenmpt 0.7.4 (upcoming stable)Fixed in VersionOpenMPT 1.31.05.00 / libopenmpt 0.7.4 (upcoming stable) 
Summary0001739: OpenMPT crashes whenever I open certain shortcuts of modules within the program itself
Description

To organize my modules, I have created shortcuts for them so they can appear in multiple folders. However, some shortcuts will always cause OpenMPT to crash if I open them within the program itself, while other shortcuts are able to be opened without any issues.

Steps To Reproduce

I'm not sure if the problem lies within the original modules that the shortcuts are based on, but in order to reproduce the issue, create shortcuts of several different modules, then open OpenMPT and try to open the shortcuts of the project files.

Additional Information

Deleting and recreating the faulty shortcuts does not fix the issue. I can still open the original modules, but only if it's the original file and not the shortcut.

TagsNo tags attached.
Attached Files
Has the bug occurred in previous versions?As far as I know, this bug has happened in every version of 1.31 so far, but I have not tested it with versions 1.30 or before.
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2023-12-31 00:13

administrator   ~0005814

Without the files provided in the path seen in the screenshot (in particular the .dmp file in that path), it's impossible to tell what's going on.

Stardown

Stardown

2023-12-31 08:20

reporter   ~0005815

Okay, thanks for telling me about that. Here's the entire folder from the path in the error message, including the .dmp file.

2023-12-30 14.56.05.zip (30,049 bytes)
Saga Musix

Saga Musix

2023-12-31 12:20

administrator   ~0005816

Thanks. The core issue here seems to be an inconsistency / bug in how Windows' file dialog resolves the linked-to filename, but nevertheless OpenMPT should not crash in that situation, even if wrong information is provided by the system. I'll find a workaround for this.

Saga Musix

Saga Musix

2023-12-31 12:28

administrator   ~0005817

Fixed in r20005.

manx

manx

2024-01-11 11:53

administrator   ~0005819

r20093 (1.31)

Issue History

Date Modified Username Field Change
2023-12-31 00:07 Stardown New Issue
2023-12-31 00:07 Stardown File Added: Screenshot 12-30-2023 14.59.00.png
2023-12-31 00:13 Saga Musix Note Added: 0005814
2023-12-31 00:14 Saga Musix Priority high => normal
2023-12-31 08:20 Stardown Note Added: 0005815
2023-12-31 08:20 Stardown File Added: 2023-12-30 14.56.05.zip
2023-12-31 12:20 Saga Musix Note Added: 0005816
2023-12-31 12:20 Saga Musix Assigned To => Saga Musix
2023-12-31 12:20 Saga Musix Status new => assigned
2023-12-31 12:20 Saga Musix Target Version => OpenMPT 1.31.05.00 / libopenmpt 0.7.4 (upcoming stable)
2023-12-31 12:28 Saga Musix Note Added: 0005817
2023-12-31 12:28 Saga Musix Status assigned => resolved
2023-12-31 12:28 Saga Musix Resolution open => fixed
2023-12-31 12:28 Saga Musix Fixed in Version => OpenMPT 1.31.05.00 / libopenmpt 0.7.4 (upcoming stable)
2024-01-11 11:53 manx Note Added: 0005819