View Issue Details

IDProjectCategoryView StatusLast Update
0001738OpenMPTGeneralpublic2023-12-12 21:43
Reportercs127 Assigned ToSaga Musix  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86 / x64OSWindows / WineOS Versionall
Product VersionOpenMPT 1.31.04.00 / libopenmpt 0.7.3 (current stable) 
Target VersionOpenMPT 1.31.05.00 / libopenmpt 0.7.4 (upcoming stable)Fixed in VersionOpenMPT 1.31.05.00 / libopenmpt 0.7.4 (upcoming stable) 
Summary0001738: Volume commands can be inserted in MOD using ctrl + scroll wheel.
Description

Although MOD doesn't support volume commands, you can still enter volume commands by scrolling your mouse while holding Ctrl.

TagsNo tags attached.
Has the bug occurred in previous versions?Probably
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2023-12-12 19:25

administrator   ~0005812

Crucially, this only happens next to a note + instrument combination and only if there isn't a regular volume command yet, because the code path for handling default volume is not guarded by format checks. I guess we have to disable this feature for MOD, because it would be strange if the first Data Entry interaction places something in a different column (having to "move" the volume effect to the regular effect column), and then it cannot continue doing anything in the volume column becuase now the "virtual" volume command is no longer shown there.

Saga Musix

Saga Musix

2023-12-12 21:43

administrator   ~0005813

Fixed in r19968.

Issue History

Date Modified Username Field Change
2023-12-12 19:09 cs127 New Issue
2023-12-12 19:25 Saga Musix Note Added: 0005812
2023-12-12 19:25 Saga Musix Assigned To => Saga Musix
2023-12-12 19:25 Saga Musix Status new => assigned
2023-12-12 21:41 Saga Musix Target Version => OpenMPT 1.31.05.00 / libopenmpt 0.7.4 (upcoming stable)
2023-12-12 21:43 Saga Musix Note Added: 0005813
2023-12-12 21:43 Saga Musix Status assigned => resolved
2023-12-12 21:43 Saga Musix Resolution open => fixed
2023-12-12 21:43 Saga Musix Fixed in Version => OpenMPT 1.31.05.00 / libopenmpt 0.7.4 (upcoming stable)