View Issue Details

IDProjectCategoryView StatusLast Update
0001655OpenMPTUser Interfacepublic2023-01-26 21:34
Reporterdem1 Assigned ToSaga Musix  
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT / libopenmpt 0.6.7 (upgrade first) 
Target VersionOpenMPT / libopenmpt 0.6.8 (upgrade first)Fixed in VersionOpenMPT / libopenmpt 0.6.8 (upgrade first) 
Summary0001655: Previewing instrument with built-in filter produces buzz

It sounds like the filter output is getting zeroed once per tick.

The buzz is produced when playing a note in the Instrument tab, whenever the built-in filter is active. There is no issue with notes triggered by the pattern.

I surmise that 18404 might have caused this, but I can't see how. I've attached my mptrack.ini, a module, and the audio output from playing a note with each instrument in that module (recorded with WASAPI loopback). Let me know if you need any more information :)

Steps To Reproduce

open "Report/",
navigate to Instrument pane,
select instrument 1 ("filter on"), play C-4,
tweak the tempo settings while instrument 1 plays,

listen and reflect

TagsNo tags attached.
Attached Files (270,505 bytes)
Has the bug occurred in previous versions?No
Tested code revision (in case you know it)




2023-01-26 13:37

reporter   ~0005506

Last edited: 2023-01-26 13:42

I was curious and checked it out. I can confirm this is happening and I have never encountered anything like this. (edit on further thought, I might encountered it but not noticed in the past, although that seems unlikely... I probably would have brought it up here)
In my curiosity I decided to try some sleuthing (for what it is worth guys) and so I converted to ompt file, turned off all the compatibility tried every resampling kind, added extended filter range, old effects, compatible gxx changed the mix levels even upsampled... nothing got rid of it and those are all the methods I could personally think of.
So saga or whomever decides to look at this, those experiments were done. My personal skills from within the software are not enough to solve this.

Saga Musix

Saga Musix

2023-01-26 14:19

administrator   ~0005507

Actually it was caused by a compatibility fix in r18431, not r18404.



2023-01-26 17:58

reporter   ~0005508

oops, sorry for the red herring! Thanks for looking into this.

Saga Musix

Saga Musix

2023-01-26 21:34

administrator   ~0005509

Fixed in r18646.

Issue History

Date Modified Username Field Change
2023-01-26 04:05 dem1 New Issue
2023-01-26 04:05 dem1 File Added:
2023-01-26 13:37 Exhale Note Added: 0005506
2023-01-26 13:42 Exhale Note Edited: 0005506
2023-01-26 14:19 Saga Musix Note Added: 0005507
2023-01-26 14:19 Saga Musix Assigned To => Saga Musix
2023-01-26 14:19 Saga Musix Status new => assigned
2023-01-26 14:19 Saga Musix Target Version => OpenMPT / libopenmpt 0.6.8 (upgrade first)
2023-01-26 14:20 Saga Musix Severity major => minor
2023-01-26 14:20 Saga Musix Reproducibility have not tried => always
2023-01-26 17:58 dem1 Note Added: 0005508
2023-01-26 21:34 Saga Musix Status assigned => resolved
2023-01-26 21:34 Saga Musix Resolution open => fixed
2023-01-26 21:34 Saga Musix Fixed in Version => OpenMPT / libopenmpt 0.6.8 (upgrade first)
2023-01-26 21:34 Saga Musix Note Added: 0005509