View Issue Details

IDProjectCategoryView StatusLast Update
0001654OpenMPTGeneralpublic2023-01-24 08:18
ReporterSome1NamedNate Assigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.30.09.00 / libopenmpt 0.6.7 (upgrade first) 
Target VersionOpenMPT 1.31 / libopenmpt 0.7 (goals)Fixed in VersionOpenMPT 1.31 / libopenmpt 0.7 (goals) 
Summary0001654: Exporting 32-bit FLAC streams
Description

FLAC 1.4 launched, adding 32-bit audio support. Will this be added to OpenMPT and libopenmpt momentarily?

TagsNo tags attached.
Has the bug occurred in previous versions?
Tested code revision (in case you know it)

Activities

Saga Musix

Saga Musix

2023-01-24 08:14

administrator   ~0005500

You have already received an answer to this question: https://forum.openmpt.org/index.php?topic=6868.0

manx

manx

2023-01-24 08:18

administrator   ~0005501

1.30 can already read 32bit FLAC since 1.30.07.

1.31 already has 32bit FLAC export with 28bit precision.

libopenmpt itself is not concerned with FLAC at all.

As for openmpt123, I would prefer to keep the export at 24bit FLAC by default because of much better hardware compatibility, and because the openmpt123 interface has no provisions for more fine-grained output format selection.

Issue History

Date Modified Username Field Change
2023-01-24 08:03 Some1NamedNate New Issue
2023-01-24 08:14 Saga Musix Note Added: 0005500
2023-01-24 08:14 Saga Musix Status new => resolved
2023-01-24 08:14 Saga Musix Resolution open => fixed
2023-01-24 08:14 Saga Musix Target Version => OpenMPT 1.31 / libopenmpt 0.7 (goals)
2023-01-24 08:15 Saga Musix Fixed in Version => OpenMPT 1.31 / libopenmpt 0.7 (goals)
2023-01-24 08:18 manx Note Added: 0005501