View Issue Details

IDProjectCategoryView StatusLast Update
0001652OpenMPTGeneralpublic2023-01-26 21:34
ReporterEddy67716 Assigned ToSaga Musix  
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionno change required 
Platformx64OSWindowsOS Version10
Product VersionOpenMPT 1.30.09.00 / libopenmpt 0.6.7 (upgrade first) 
Summary0001652: Exporting percussion channels as mapped always maps to C4 (Tracker C5) High bongo
Description

In the wiki, it says that when you chose mapped percussion, it should map percussion using the MIDI standard, e.g. Tracker C-3 becomes a bass drum and tracker D-3 becomes a snare. But when I export MIDI, it is all mapped to C4 (tracker C5) and sounds like a high bongo.

Steps To Reproduce

Write a drum line with MIDI drum mapping (C-3 is bass, D-3 is snare, etc.), Click Export to MIDI, Set MIDI channel to percussions (or 10 in the instrument panel) Set MIDI program/percussion to mapped. Export the file and all drum notes are mapped to C4 (High bongo)

TagsNo tags attached.
Has the bug occurred in previous versions?Yes
Tested code revision (in case you know it)

Activities

Eddy67716

Eddy67716

2023-01-14 10:28

reporter  

Screenshot 2023-01-14 205444.jpg (149,618 bytes)   
Screenshot 2023-01-14 205444.jpg (149,618 bytes)   
Saga Musix

Saga Musix

2023-01-14 11:11

administrator   ~0005484

Mapped percussions still take the instrument's note map into account. So if all notes in the corresponding instrument's note map are mapped to C-5, then this is the note that will be recorded to the MIDI file. So maybe the instruments that you are using for export are all mapped to C-5 in the note map?

Eddy67716

Eddy67716

2023-01-15 21:40

reporter   ~0005487

Then the wiki should be changed to reflect that change because it says it maps pattern notes and not the note sample map.

Also you should add an option to map by pattern to make it easier for music tracker composers to map based on pattern notes.

Capture.PNG (6,006 bytes)   
Capture.PNG (6,006 bytes)   
Eddy67716

Eddy67716

2023-01-15 21:42

reporter   ~0005488

Last edited: 2023-01-15 21:45

Also, this was my note map. 1 is a base drum sample, 2 is snare, 3, open hi-hat; 4, closed hi-hat; 5, ped hi-hat; 6, low tom; 7, high tom; 8, floor tom and 9, (not shown on screenshot, but mapped as C#4) is a crash cymbal.

Capture-2.PNG (3,824 bytes)   
Capture-2.PNG (3,824 bytes)   
Saga Musix

Saga Musix

2023-01-15 21:45

administrator   ~0005489

The wiki has been updated.

Also you should add an option to map by pattern to make it easier for music tracker composers to map based on pattern notes.

This is not really feasible due to how MIDI export works internally. The component that processes the MIDI data is no knowledge of pattern notes.

Also, this was my note map.

With a note map like that, you should be able to right-click and choose "Transpose Samples / Reset Map". This will convert the map into a format that will also be recognized by MIDI export the way you expected it.

Issue History

Date Modified Username Field Change
2023-01-14 10:28 Eddy67716 New Issue
2023-01-14 10:28 Eddy67716 File Added: Screenshot 2023-01-14 205333.jpg
2023-01-14 10:28 Eddy67716 File Added: Screenshot 2023-01-14 205444.jpg
2023-01-14 10:36 Eddy67716 Description Updated
2023-01-14 11:11 Saga Musix Note Added: 0005484
2023-01-14 11:11 Saga Musix Assigned To => Saga Musix
2023-01-14 11:11 Saga Musix Status new => feedback
2023-01-15 21:40 Eddy67716 Note Added: 0005487
2023-01-15 21:40 Eddy67716 File Added: Capture.PNG
2023-01-15 21:40 Eddy67716 Status feedback => assigned
2023-01-15 21:42 Eddy67716 Note Added: 0005488
2023-01-15 21:42 Eddy67716 File Added: Capture-2.PNG
2023-01-15 21:45 Saga Musix Note Added: 0005489
2023-01-15 21:45 Saga Musix Status assigned => feedback
2023-01-15 21:45 Eddy67716 Note Edited: 0005488
2023-01-26 21:34 Saga Musix Status feedback => closed
2023-01-26 21:34 Saga Musix Resolution open => no change required