View Issue Details

IDProjectCategoryView StatusLast Update
0001649OpenMPTGeneralpublic2023-01-24 10:23
ReporterSaga Musix Assigned Tomanx  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product VersionOpenMPT 1.30.09.00 / libopenmpt 0.6.7 (upgrade first) 
Fixed in VersionOpenMPT 1.30.10.00 / libopenmpt 0.6.8 (current stable) 
Summary0001649: Updating with no modules open causes an empty module to be opened after restart
Description

Steps to reproduce

1) Launch new OpenMPT instance, no modules opened
2) Receive notification about new OpenMPT version
3) Accept update
4) OpenMPT is updated and restarted
5) Observe that an empty Module1 is opened.

TagsNo tags attached.
Has the bug occurred in previous versions?Yes, since introduction of new update feature
Tested code revision (in case you know it)

Activities

manx

manx

2023-01-09 11:50

administrator   ~0005457

Reproducible in debug build by using a fantasy restart GUID as a commandline argument: /RestartByRestartManager:5854CEDB-CB94-4601-8B84-3124F7E82D3B.

manx

manx

2023-01-09 12:38

administrator   ~0005458

Fixed in r18485 (trunk) and r18486 (1.30).

Issue History

Date Modified Username Field Change
2023-01-09 09:38 Saga Musix New Issue
2023-01-09 10:17 Saga Musix Product Version => OpenMPT 1.30.09.00 / libopenmpt 0.6.7 (upgrade first)
2023-01-09 10:17 Saga Musix Has the bug occurred in previous versions? => Yes, since introduction of new update feature
2023-01-09 11:08 manx Assigned To => manx
2023-01-09 11:08 manx Status new => assigned
2023-01-09 11:50 manx Note Added: 0005457
2023-01-09 12:38 manx Status assigned => resolved
2023-01-09 12:38 manx Resolution open => fixed
2023-01-09 12:38 manx Fixed in Version => OpenMPT 1.30.10.00 / libopenmpt 0.6.8 (current stable)
2023-01-09 12:38 manx Note Added: 0005458