View Issue Details

IDProjectCategoryView StatusLast Update
0001613OpenMPTPlayback Compatibilitypublic2022-08-14 20:42
Reportermrpapersonic Assigned To 
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version7
Product VersionOpenMPT 1.31.00.* (current testing) 
Target VersionOpenMPT 1.31 / libopenmpt 0.7 (goals)Fixed in VersionOpenMPT 1.31 / libopenmpt 0.7 (goals) 
Summary0001613: S3M: OPL2 samples shouldn't be affected by Gxx
Description

In Scream Tracker 3.21, Gxx is ignored when it's used on OPL2 samples, but OpenMPT adds it anyway.

Steps To Reproduce
  1. Create a new S3M file
  2. Make any OPL2 sample
  3. Use a tone portamento on the sample
TagsNo tags attached.
Has the bug occurred in previous versions?Since 1.28.01.00
Tested code revision (in case you know it)17648

Activities

Saga Musix

Saga Musix

2022-08-14 13:21

administrator   ~0005275

I cannot confirm that this is unconditionally true. At least sliding back to the original note appears to be possible. See attached example.

portAdlib.zip (263 bytes)
Saga Musix

Saga Musix

2022-08-14 13:34

administrator   ~0005276

It also appears like the note with the portamento effect is delayed until the next row.

Saga Musix

Saga Musix

2022-08-14 13:38

administrator   ~0005277

portAdlib-2.zip (291 bytes)
Saga Musix

Saga Musix

2022-08-14 13:45

administrator   ~0005278

portAdlib-3.zip (308 bytes)
Saga Musix

Saga Musix

2022-08-14 14:34

administrator   ~0005280

Fixed in r17731.

Saga Musix

Saga Musix

2022-08-14 20:37

administrator   ~0005283

Last edited: 2022-08-14 20:42

Addendum: This feature still worked as intended in ST3.01, only in ST3.03 onwards it's broken. Skaven's "First Adlib Attempt" S3M breaks with this fix, so it is now only applied in S3Ms made with later versions of ST3.

Issue History

Date Modified Username Field Change
2022-07-08 19:53 mrpapersonic New Issue
2022-08-14 13:21 Saga Musix Note Added: 0005275
2022-08-14 13:21 Saga Musix File Added: portAdlib.zip
2022-08-14 13:34 Saga Musix Note Added: 0005276
2022-08-14 13:38 Saga Musix Note Added: 0005277
2022-08-14 13:38 Saga Musix File Added: portAdlib-2.zip
2022-08-14 13:45 Saga Musix Note Added: 0005278
2022-08-14 13:45 Saga Musix File Added: portAdlib-3.zip
2022-08-14 14:34 Saga Musix Note Added: 0005280
2022-08-14 14:34 Saga Musix Status new => resolved
2022-08-14 14:34 Saga Musix Resolution open => fixed
2022-08-14 14:34 Saga Musix Fixed in Version => OpenMPT 1.31 / libopenmpt 0.7 (goals)
2022-08-14 14:34 Saga Musix Target Version => OpenMPT 1.31 / libopenmpt 0.7 (goals)
2022-08-14 20:37 Saga Musix Note Added: 0005283
2022-08-14 20:42 Saga Musix Note Edited: 0005283